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SAFR™ is exceptionally accurate facial recognition integrated with Milestone XProtect®. Through vigilant 24/7 
monitoring — with live video overlays, automatic bookmarks, and real-time alarms — SAFR taps the power of 
AI to overcome the limits of physical security by providing enhanced visibility and situational awareness. 
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I. Introduction 
If you are already familiar with Milestone XProtect® and what SAFR is all about, then this quick guide can 
provide you with all you need to get the two working together. You will: 

• Add a user to XProtect® to use for SAFR access. 
• Create an Overlay Metadata Driver on the Milestone server for each camera. 
• Ensure the SAFR Desktop app is installed, and the Milestone tab has Milestone server settings configured 

and connected to at least one camera. 
• Ensure SAFR Desktop app mode is correct for the events you want triggered. 

While this guide describes how to use SAFR from RealNetworks together with Milestone XProtect®, it does not 
attempt to take the place of the full user and system administration guides for either product. For more 
information on either SAFR or Milestone Applications, review the documentation available from the respective 
download portals. 

About SAFR 
SAFR from RealNetworks is a highly accurate facial recognition platform powered by artificial intelligence that 
works with IP cameras and readily available hardware to match faces in real time. SAFR provides industry-
leading performance to offer the following capabilities: 

• Scalability that can reliably match against millions of faces in under a second. 
• Targeted design to specifically recognize faces in real-world conditions, including people in motion, in dim 

lighting, and at occluded angles. 
• Non-literal matching that handles multiple variations, including masks, makeup, spectacles, hair styles, and 

aging. 
• High tolerance to yaw, tilt, and rotation. 
• Error rate tuning to minimize false rejections and false acceptances, or to optimize between the two. 

RealNetworks computer vision topped the list for labeled faces in the wild (LFW), achieving a 99.86% accuracy 
in a test conducted by the University of Massachusetts, and 0.021 for Wild Faces FNMR, according to the 
National Institute of Standards and Technology (NIST). 

About SAFR for Milestone 
SAFR works by analyzing videos and can be connected to cameras managed by Milestone. SAFR processes each 
video feed to detect faces and attempt recognition. The Milestone video feeds are enhanced by adding 
overlays to show detected faces and information about each face, such as ID class (Stranger, No Concern, 
Concern, or Threat), age, gender, and emotion, all of which are optional. This information and any other 
metadata associated with a recognized person are also passed to Milestone for use in alerting. 

About Events 
SAFR defines events that allow you to take action on different scenarios. Scenarios are grouped by the 
following: 
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Grouping Description 

ID Class A known person marks as either: 

• Threat 
• Concern 
• No Concern (not a threat or concern). 
• Stranger (face detected but not previously 

registered) 
• Unrecognizable (face detected but not of 

sufficient quality for recognition) 

Person Type A label defined to identify a person; for example, 
staff, visitor, or VIP. These are defined on the SAFR 
People management page. 

Name (Optional) Enrolled person's first and last name. 

Note: Person Type and Name are not applicable for the ID Class of Stranger or Unrecognizable. 

Combinations of the three attributes described in the table are used to make a total of 14 possible events. 
Following are the events SAFR can generate: 

• Unrecognizable face detected. 
• Stranger detected. 
• Enrolled person detected without name. 
• Enrolled person detected with name <name>. 
• Enrolled person detected of type <personType>. 
• Enrolled person detected of type <personType> with name <name>. 
• Concern person detected without name. 
• Concern person detected with name <name>. 
• Concern person detected of type <personType>. 
• Concern person detected of type <personType> with name <name>. 
• Threat person detected without name. 
• Threat person detected with name <name>. 
• Threat person detected of type <personType>. 
• Threat person detected of type <personType> with name <name>. 

About SAFR-Triggered Actions 
Any of the SAFR events listed can be used to trigger an action in Milestone. For example: 

• A SAFR Threat event can be used to trigger a notification to the security guard and lock doors. 
• A SAFR alert for one or more known people types can be used to suppress a motion alert to reduce alarm 

fatigue. 
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These are just some of the examples. Any action supported by Milestone can be triggered by any of the SAFR 
events. 

Bookmarks 

SAFR creates bookmarks for every event generated. Bookmarks contain the event message; any string in a 
bookmark can be used to find the events associated with that string. 

II. Planning Your System 
SAFR allows you to add face detection and recognition to your Milestone cameras. For any of your cameras 
where face detection events and bookmarks only are required (no overlays), a single stream license for each 
camera is required. If you are licensed for 300 cameras with Milestone, then you can create face detection 
events and bookmarks for all 300 cameras with SAFR. 

If you want to also display overlays for each of your cameras, an additional stream license is required for each 
camera. For example, if you have 300 cameras, then you need 600 stream licenses to process events, 
bookmarks, and face overlays with SAFR. 

Following is an example of how SAFR is deployed with Milestone XProtect®: 

 

A typical deployment requires the following computers: 

• Milestone XProtect® 
• One or more machines running SAFR Desktop to process videos 
• Milestone XProtect® and Milestone Admin Tool at monitoring locations 

Cameras are connected to Milestone XProtect®. The SAFR app can then connect to Milestone XProtect® to 
perform analysis of the video and add overlays. Depending on the number of cameras you need, one or more 
machines can run SAFR Desktop, each processing multiple video feeds. The SAFR app processes the video and 
returns information to Milestone to overlay the video feeds and generate events. The SAFR Desktop app is also 
used to perform various management activities. This could be run on the same system as Milestone 
Management Client. 
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System Requirements 
Software 

• Milestone XProtect® 2019 R1 or later 
• RealNetworks SAFR Desktop for Windows 1.4.142 or later 
• For local deployment, SAFR Platform Milestone Edition 1.4.140 or later (not required if using SAFR Cloud) 

License Requirements 

• Each video stream processed by SAFR for events and bookmarks requires one license stream 
• Each video stream being processed by SAFR for events, bookmarks, and video overlays requires two license 

streams 
• A Milestone license for the number of video streams needed is acquired through Milestone 
• A SAFR license for the number of video streams needed is acquired through RealNetworks 

SAFR Desktop System Requirements 

• Windows 10 
• 16GB RAM 
• Quad Core i7 CPU (6 core or better recommended with NVIDIA GTX 1050Ti, GTX 1060, GTX 1070Ti or GTX 

1080Ti graphics card for enhanced performance) 

SAFR Desktop can process video for multiple cameras depending on your load and size of the video feed. 

Configure Milestone 
Following are the steps required to allow SAFR to connect Milestone XProtect® to process video streams or 
facial recognition. 

1. Create a SAFR user. 

To work with SAFR, Milestone users are required to create a SAFR role and include minimum camera 
permission. In this way, along with updating Operator role permissions, SAFR related functionality 
works correctly. For more information on creating users and setting permissions, refer to Milestone 
XProtect end user documentation. 

To create a SAFR user and set permissions, do the following: 

• Add a SAFR user (for example, safr-roles) in the Milestone XProtect Management Client > 
Site Navigation pane > Security > Roles. 

• Once safr-roles is created, add the required SAFR camera permissions to the role in the 
Milestone XProtect Management Client, Site Navigation pane > Security > Roles > Overall Security. 
From Role Settings > Camera, select Allow for the following check boxes:   

o Read 
o View Live 
o Create bookmarks 
o Read bookmarks 
o Edit bookmarks 
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Note: SAFR functions but bookmarking does not work correctly without the Edit Bookmarks 
permission. 

2. Update Milestone XProtect operator permissions. 

So Milestone operators can view SAFR overlays, update the Operator role–or the role you are using to 
log into the Milestone XProtect Smart Client) to allow display of live metadata.  

• Set Operator role permissions in the Milestone XProtect Management Client > Site Navigation 
pane > Security > Roles. Click Operator > Overall Security. From Role Settings > Metadata, edit 
by selecting Allow for the Live check box. 

Note: Overlays are not visible if the Live permission is not added to the Operator role. 

3. Install SAFR. 

From SAFR Download Portal, download the SAFR Desktop for your platform. 

• For Windows machines, the full version is intended for machines with NVIDIA video cards. With an 
NVIDIA card installed, you can realize significantly improved performance. 

• After installation, proceed to Configuring SAFR app below. 

Connecting SAFR with Milestone using the following steps: 

• Start the SAFR app through the Windows Start menu, Mac applications folder, or iOS/Android 
desktop. 

• Sign in to your SAFR Cloud. Your regional SAFR Technical Representative can help you obtain sign-
in credentials. 

• Once signed in to SAFR, from the Tools menu, select Preferences to connect SAFR to Milestone. 
• Click the Milestone tab as shown in the following illustration: 

 

http://safr.int2.real.com/download
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Note: If the Milestone Preferences tab is not displayed, you may have installed an incorrect version of 
SAFR Desktop. Ensure you have downloaded the Milestone Edition of SAFR Desktop. 

• Enter information in the Milestone tab to connect to Milestone XProtect® server, and click OK. 
o Username: User created previously in Configure Milestone 
o Password: Password created for SAFR user 
o Directory: IP address of server running Milestone XProtect® 
o Check Windows credentials if the user is a Windows system user 
o Overlay Setup 
o Overlay Password: This password is used in setting up the metadata drivers 

4. Create overlay metadata driver on Milestone Server for each camera. 

Open Milestone XProtect Management Client. In the left pane, under Servers, click Recording Servers. 
In the center pane, right-click the appropriate server name, and click Add Hardware.  

 

In the dialog, click the Manual option, and click Next. 

 

If not already in the list, click Add to include the password from the SAFR > Preferences > Milestone 
tab Overlay Password field. Include a user name of your choice. Click Next. 
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Click Clear All, select Milestone only, and click Next. 

 

Add the address (IP) and port number of the SAFR client active overlay connections. To find this 
information, go to SAFR > Properties > Milestone tab, and click Active Overlay Connections. The dialog 
provides a table of camera names, IP addresses, and port numbers. 
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From the Hardware Model menu, select MIP Driver. Click Add to create more rows for additional MIP 
driver addresses and ports if needed. Click Next. 

 

On connection success, click Next. 
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Select the Metadata check box. It is recommended you click the Name field for the MIP driver and 
rename it to include the name of the camera to assist you when associating the camera with the MIP 
driver later. Click Next to add the hardware. 

 

From the Add to Group menu, associate the MIP driver with a specific metadata group to make it 
easier to locate. Click Finish. 
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If the menu does not include a choice, or if you receive an Assign Device to a Device Group message, 
do the following: 

• In the left list, to the right of the Default Metadata Group field, click the folder icon. 
• In the Select Group dialog, in the lower-left corner, click the folder-plus icon to add a group. 

 

• Provide a name for the device group, and click OK. 

 

• From the Add to Group menu, you can now select the new device group. 

Once the driver has an associated device group, click Finish. 

5. Associate the MIP device with the camera. 

In the Milestone XProtect Management Client, in the left pane, click Recording Servers and expand 
the tree view to display the cameras and MIP drivers. 

 

With the camera highlighted, in the right-pane, at the bottom of the window, click Client. 
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Under Client Settings > Related Metadata, click the  button. 

 

In the Select Devices dialog, on the Device Groups tab, click to highlight the MIP device you renamed 
earlier for easy identification. Click Add so that the device appears in the Selected pane. Click OK. 

 

In the right Related Metadata field, the MIP device name is displayed and is now associated with the 
highlighted camera in the left pane. 

Explanation of Milestone Connection Preferences 

• Milestone server (used for enumerating cameras as well as publishing events and bookmarks): 
o Username 
o Password 
o Directory (IP address or Host Name of a Milestone server) 
o Windows credentials if user is Windows system user 
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• Additional options (defaults work for most purposes): 
o Draw Overlays 

Ovals, names, and other details are drawn to the video stream so it appears in 
Milestone software. Drawn information matches what would show in SAFR Desktop, 
so non-Milestone settings that affect SAFR Desktop affect what is drawn to 
Milestone. 

Control over which overlay elements are drawn on video streams are configured 
from the SAFR View menu. Choices include: 

• Tracking Frames 
• Attributes (gender, age, sentiment) 
• Names 
• Full-Screen Name 
• Recognition Details 
• Video 
• Detection List 
• Performance Metrics 

In addition, under SAFR > Preferences > User Interface, the following control the appearance 
of the overlays: 

o Name Display Time 

This is the amount of time the full-screen recognized person name appears. 

o Highlight Border Thickness 

This controls the thickness of the frames drawn around the faces in the video. 

o Overlay Text Size 

This controls the size of the text used to display person’s name under their face. 

o Overlay Password 

This is used in creating the overlay driver. 

o Report Events 

Only events reported to the SAFR Events server are reported to Milestone. 

o Include Event Details 

Increases the verbosity of events in attaching JSON to the event that includes all of 
the technical details of the event. This is useful if an operator is using macros to 
handle the event for decision-making. 

o Insert Bookmarks 

Adds bookmarks to the video stream related to events. Allows operators to search 
video for events or recognized person names. Use caution when deciding what to 
include since many faces can cause many bookmarks to be created. 
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o Include Unrecognizable Faces 

Adds bookmarks when a face detected by SAFR does not have enough information to 
determine if it is a stranger or known person. This can become visually noisy and is 
disabled by default. Generally useful for areas where nobody should enter. 

o Include Strangers 

Adds bookmarks when a face is determined to be a stranger. Generally useful for 
secured areas where only known people should be. 

o Include Enrolled 

Adds bookmarks when a face is determined to be a known person. 

o Include Concerns and Threats 

Adds bookmarks when a face is determined to be a known concern or threat. 

SAFR Modes 

SAFR has different modes to control what events are generated. The following is a short summary of the 
modes most relevant to Milestone XProtect® integration. For a complete description, see the SAFR 
Administration Guide. 

• Secure Access: Trigger events only for cardholders (or persons registered directly in SAFR) only when there 
is a high confidence match. Useful for secure entry (for example, unlocking doors). 

• Smile to Unlock: Same as Secure Access but includes an additional trigger event if the user smiles. 
• Enrolled Monitoring: Trigger events for cardholders (or persons registered directly in SAFR) but with lower 

confidence. 
• Enrolled and Stranger Monitoring: Same as Enrolled Monitoring but triggers events for strangers also. 

Verify your connection: 

To verify successful connection to the Milestone system, open Preferences > Camera tab. Cameras connected 
to the Milestone system should be visible. All cameras connected to the Milestone system have a Milestone 
prefix in their names. 

Connect Your Cameras to Milestone 

Initially, you need to add the camera to Milestone using the admin tool. The best information on how to do 
this is the Milestone XProtect® Administration Guide. However, what follows is a brief explanation of the 
procedure: 

1. Open the Administration client. 
2. Go to Recording Servers. 
3. Right-click the Recording Server to which you want to add a camera. 
4. Select Add Hardware. 
5. Select a method to auto-discover the camera. For this example, use auto-discover. 
6. Check the box next to each manufacturer of the cameras you want to add. Click Next. 
7. Add any username and password combination used to connect to the camera. 
8. Cameras appear in the list as they are discovered. Check the box next to each camera you want to add. 
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9. The hardware for each camera is listed. Check the box for each part to be added. Types of parts are camera 
feeds, microphones, speakers, and others. 

10. Hardware parts need to be added to groups. At the left, select the default group for each type of hardware. 
At the right, you can override the group for individual hardware parts. 

11. Click Finish to add the selected hardware. 

Connecting SAFR to Milestone Video Feeds 

Once the camera is in the Video Archiver, it shows up as a Milestone camera in SAFR. If it does not, try closing 
and re-opening SAFR. 

To get the SAFR enhancement to show up on the Milestone camera feed: 

1. Open the SAFR Desktop. 
2. Select the Milestone version of the camera (it has Milestone as the first part of the camera name) from the 

menu in the main windows (upper left). 

On successful connection to the Milestone camera, video from the camera plays in the SAFR Desktop window. 

You can see the enhancements by watching the camera's video feed in XProtect®: 

1. Open XProtect®. 
2. Go to the Monitoring Task. 
3. Drag and drop a camera from the left side into one of the tiles in the middle. 

The camera feed should start up and show the same overlays that are in SAFR (for example, ovals, names). 

To connect to additional cameras: 

1. Open another instance of SAFR Desktop by selecting New from the File menu. 
2. Repeat the previous steps to connect to a different Milestone camera feed.  

On successful connection to the Milestone camera, video from the camera plays in the SAFR Desktop window. 

3. Repeat this process for as many video feeds as desired (up to the capacity of the machine SAFR is installed 
on). 

4. If more capacity is needed, install SAFR on additional machines and repeat the setup process. 

Note: By default, SAFR Desktop for Milestone operates in Enrolled Monitoring mode and generates events and 
bookmarks into Milestone system for every enrolled person. If a different mode is desired for selected camera, 
choose a different mode from the video window mode selector menu. 

Restoring SAFR State 

When you quit, SAFR stores its state and restores the state upon startup. When restarted, SAFR opens with the 
same number of windows and each window restores its previous settings, including the camera to which it was 
connected. 

Warning: When closing SAFR, from the File menu, use Quit SAFR. Closing SAFR using the Window Close button 
only closes the window and you lose the state—settings and connected camera—for that window. 
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Adding Identities 

You can add people through SAFR Desktop or through SAFR APIs. This can be useful for adding threats or 
concerns or other enrolled people who may not be suitable as cardholders. To add people through SAFR 
Desktop from an image or video file, do the following: 

1. Open SAFR Desktop. 
2. Click File > Import Faces. 
3. Select the image. 

• For an image, each recognized face is enclosed by a box, and you have the option to type a name. 
• For a video, each recognized person is learned automatically as long as the faces meet the minimum 

criteria for recognition. 
4. If faces are not learned, check the settings in the Detection and Recognition tabs in Preferences to ensure 

faces meet minimum criteria. 
• Detection > Minimum searched face size 
• Recognition > To allow identification 

Warning: Reducing detection and recognition settings lowers the quality of the reference face and negatively 
impacts recognition. It is preferable to increase the quality of your sources than to lower the criteria for 
learning. 

Warning: Users added to SAFR are not synchronized to Milestone. These users exist only in SAFR. 

Editing Identities 

It may be desirable to edit people properties to control which events get triggered when that person is 
recognized. For example, setting a person's ID Class to Concern or Threat triggers the respective alarms, or 
changing a person type to trigger a VIP alert for specific cardholder groups. The most important people 
attributes are the name, image, person type, and ID Class. 

Attributes Edited through SAFR 

The name, image, or person type should be edited through SAFR. Person type defines a person’s role (for 
example, staff or visitor), while the ID Class defines the risk level (No-Concern, Concern, or Threat). Person 
Type or image can be edited in SAFR Desktop by changing the Person Type on the People screen.   

ID Class and any other attributes of a person are also edited within SAFR People dialog, accessed through the 
SAFR app Tools menu. All identities are created by default with an ID Class of Normal or No Concern. 
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To edit the ID Class of a person, open the People window from the SAFR Desktop Tools menu as follows: 

 

The Person Type and name can be edited by clicking the respective fields on the People screen. To edit ID 
Class, double-click the user and choose the desired value from the ID Class menu in the People Edit dialog as 
shown in the following illustration: 

 

SAFR for Milestone XProtect® Features 

This section describes how SAFR enhances the Milestone XProtect® application through monitoring, viewing 
recognition alarms, and bookmarks. 

Monitoring 

SAFR for Milestone enhances video monitoring by providing overlays that gives the security personnel more 
information, including person types, threat classification, and name. It can even be used to augment the video 
views with age and gender information that may be useful in reporting suspects. 
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The following illustration shows how overlays give more information about the subjects in view: 

 

In the previous illustration, you see a registered named user (top left), and a known threat (top right). It also 
shows a stranger tailgating a known user in the bottom left screen. The information is conveyed as name and 
color. The following list describes the different colors used in SAFR overlays: 

• Gray (Unrecognizable): The face does not meet minimum quality values and recognition cannot be 
attempted, or a response from attempted recognition has not yet arrived. 

• Purple (Stranger): The face meets sufficient quality for recognition but is not recognized and does not meet 
minimum quality to be learned. 

• Blue: The face is recognized as matching one already in the database. It is blue rather than green since it 
has no assigned name. 

• Green: Registered person with a name. 
• Yellow: The face has just been learned (recorded in the database). 
• Red (Threat): Registered face tagged as a threat. 

Viewing Recognition Alarms 

You can also use SAFR to view recognition events. Recognition events occur when a known, unknown, or 
unrecognized person appears in the view of a camera. The types of recognized persons are: 

• Unrecognizable: The face is detected but not of sufficient quality to attempt recognition. 
• Stranger. 
• Enrolled person, with or without name. 
• Enrolled person marked as Threat or Concern. 
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There are 12 different combinations of these conditions that are triggered. The following illustration shows 
multiple events populated in the Milestone alerts panel: 

 

Note: Clicking any of the events on this screen allows the video from that event to be replayed. 

Bookmarks 

SAFR for Milestone creates bookmarks to help locate important events. Bookmarks are populated with person 
type, ID class, and name as described previously. They can also provide more detailed information with even 
more search attributes, such as age and gender.  
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The following illustration shows how bookmarks can be used to review important events, such as the detection 
of a stranger tailgating behind a registered user. 

 

Note: The purple indicator identifies the person is a stranger. 

Troubleshooting Tips 

• If detection or recognition results in not many faces found or recognized, check that the Milestone video 
feeds are of a sufficiently large frame size. 

• If events are not being triggered, ensure the SAFR Mode is selected. 
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