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1. System start
In the following it has been assumed that the Pro02 server and the web client are started at one 
workstation. Double-click the "gemos4start_app.bat" file to start the GEMOS. The Pro02 server and web 
browser with the corresponding address (e.g. http://localhost/) are started via this file. Both program parts 
can be started separately.

To start the Pro02 server Double-click the left mouse button on the file pro02srv.exe in the folder \bin in
the GEMOS installation directory (normally c:\program files\GEMOS\). The 
Pro02 server can also be activated automatically as a service. It is only 
necessary to log in to the system in this case.

The operator is prompted to log in at the homepage that opens next (login name, password and selection 
of the start menu). For security reasons, each operator must log in to GEMOS. The operator will always be 
prompted to do so when the program is launched or if operators change.

Figure 1.1: Login dialogue box

Login name: Entry of name to log in to the system. Upper case / lower case as well as extra or 
missing blank spaces must be observed. The login attempt fails when the data 
input is incorrect.

Password: Entry of password to log in to the system. The password can consist of numbers, 
letters and special characters. The characters entered appear as "*" on the screen 
for security reasons. After entering the password, press the Login button to confirm 
your input. If the input is incorrect, you will have to enter the data again.

Start with: Selection of the desired login type via the menu:

Default setting, change password, service, master data, system overview, 
visualisation, access control (if the module is installed)
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1.1 Instructions for use

There are two ways to access the "master data" area:

• Login at the GEMOS user login via the user interface (visualisation) followed by selection of 
master data

• Login via the GEMOS user login with master data

Additional login options are:

• Login via the GEMOS user login with change password

• Login via the GEMOS user login (see fabricator manual)

Functions, buttons and icons are available depending which license type has been acquired. In the manual,
buttons or links are underlined.

The method for accessing the individual functions, buttons or links in the master data is shown for example 
as follows: Master data > Basic configuration > User interface > Basic settings

As soon as a function is selected by clicking an additional button, a new tab in which the relevant master 
data is displayed opens in the same browser window. This allows the user to conveniently toggle between 
the different views.

Buttons and icons and field entries that apply in general may appear in several screens. These are not 
described below.

Cancel Cancels the current operation
Edit Opens the input screen for further processing
Help Calls up the online help for the individual areas
Add Adds folders, devices, areas, detectors, etc.
Delete Deletes the corresponding element
Save Saves the data to be incorporated into the database 
Test Performs test
Apply Applies the specified properties
Back Opens the previous screen

 Refresh

 Edit

 Print
 Favourites

 /  Close/open window content
 Help

 Add
 Folder symbol

 Close
 Save

 /  Search window (grey = not active, yellow = active)
 Back

Confirmation of input

Reason for change: Enter reason for the change for subsequent traceability
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Important points in the manual are marked by the following symbols:

Take special note of these passages in the event that an action carried out has not achieved 
the desired result.

Detailed instructions and tips are provided next to this symbol for the quicker or easier 
accomplishment of a task.

The master data tree is on the left-hand side of the screen. Depending on which sub-area of the master 
data was previously selected, the master data tree may contain parts of the hierarchy, the measures plans, 
the technical view or similar. Click on an object in the tree to edit it.

The data for the object selected is displayed on the right-hand side for editing. For clarity of overview, the 
data and characteristics of the object are grouped in several "register tabs". To select a register, click the 
relevant tab in the page header.

Press the  button in the page footer to save the changes. You can also use the keyboard shortcut 
Ctrl+S.

Press the  button to delete the object.

Further buttons appear depending on the type of object selected.

Press the  symbol at the top of the form on the right to register the object selected as a favourite for the 
specific user. The saved favourites are displayed at the bottom on the left below the master data tree and 
can be selected here directly. To delete a favourite, press the  symbol in the list of favourites.

Press the  symbol to navigate back to the object previously selected.

Press the  symbol to display the online help.

1.2 Master data user interface

To access the GEMOS master data user interface go to Master data. This consists of the Master data, 
Reports/Monitoring, Tools, Basic configuration and Help menus.

See Figure 1.2Welcome to the GEMOS master data

Figure 1.2: Welcome screen for the GEMOS master data
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Master data Input and administration of the data for technology, hierarchy/layouts (location 
plans), measures plans, import of data, software areas, user administration, 
persons/contacts, telephone books and overall tree.

Logs/Monitoring View of interface status, message logs, detector statuses (also searching), call 
logs, modifications reports and server logs.

Tools Simplification of work steps when deleting alarm stack, power tools and 
download and inspection of files on the server or on interface computers

Basic configuration Input of basic system settings in the user interface (presentation, framesets), 
message processing, addresses and contact management, video and telephony
control, modules, interfaces and additional templates and tools. Parts of the 
basic configurations are only required when setting up a system and are 
therefore described in detail in the manual for installers.

Utmost care must be taken when using this function in a system in production mode.

Help Calls up the online help for the program (entries can be made by the 
user/operator/installer on-site), information on the system and the project 
documentation

Each time a function is called up in the menu, a new register (tab) opens in the working area. Click the 
required tab to switch between tabs and click the  icon in the corresponding tab to close it.

If several tabs of the same type (e.g. two technical views) are open, make sure that work is not lost by 
editing the same object twice. The last click on Save saves the data!

1.3 Searching for master data elements

The following applies whenever the possibility arises to search for elements in GEMOS (in the user 
interface, the master data, in the layout editor, with links, …):

 This symbol indicates that the field in which the search term can be entered is active.

Examples:

Searching for elements based on the designation in the master data:

enter the search term in the usual manner as text. The system then searches for the element in the 
corresponding descriptions. For example, when the search term "kitchen" is entered, all elements 
containing the term "kitchen" will be displayed – location plans, signal points of BMA, persons (chef),...

Searching for elements using the Pro02Id:

"/" is prefixed to the search term. Example: a search for "/dev_enet:1/MG:23:1" finds the element with this 
Pro02Id

Searching for elements using the IID:

a"#" is prefixed to the search term. Example: a search for "#1225" finds the element with this IID, a 
software area for example
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1.4 First steps

In order to perform the initial steps when setting up a GEMOS4 system, a suggested list of individual 
actions and accompanying operating steps is provided below:

Action operating steps

Preparation of a basic structure with Prepare frameset taking the resolution of the 

assistance of performance specification monitors and views required by the operator into account

Structuring of system  Master data/Hierarchy menu, create folder according to 
technical views,

(Building/Storeys) Hierarchy views (floor plans)

Provision of required graphics Import of graphics into the import folder

Preparation of location plans Master data/Hierarchy menu, create in plans in the folders

Configuration of reporting points Master data/Technical view menu, import signal points from 
the systems, enter message texts accordingly and link to 
location plans

Configure alarm stack Basic configuration/Message processing, create priorities and
categories

Prepare actions in the event of an alarm Master data/measures (plans), prepare measures and 
measures plans and link signal points accordingly

1.5 Further structuring of the manual

The manual is subsequently structured in a certain chronological sequence, as is to be expected from the 
sequence of the tabs in the master data interface. Irrespective of this, the procedure for creation of a new 
GEMOS project as described under 1.3 is recommended.
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2. Master data
The functions in this menu open different views of the master data of the facility. Several views can be open
at the same in the working area. Each view is normally split into two parts: the master data tree on the left 
in which the data sets are selected for processing and the detailed view of the selected data set on the right
which is displayed as the master data form.

The master data is grouped into the master data itself, the logs/monitoring, the tools, the basic 
configuration and online help (see menu bar)

Figure 2.1: Groups of Master Data

The following groups can be processed by pressing the Master data button:

Technical view contains the connected subsystems and their reporting points

Hierarchy/Layouts contains the user's view of the facility with the following master data objects.

Measures (plans) contains actions that must be taken in the event of an incoming message.

Data import contains imported graphics, documents and detector lists.

Software areas contains software areas in which detectors/signalling groups are combined, e.g. 
cut-off zones.

User administration contains users and user groups with the option of assigning corresponding 
rights

Persons/Contacts addresses, telephone numbers and personal data are administered here. This 
can, for example, be persons with access authorisation, and also contacts who 
are to be notified in the event of an alarm.

Telephone books contains common telephone books to be used as part of the telephony panel

Overall tree contains the tree view of the master data

2.1 Technical view

The technical view shows the subsystems connected to GEMOS and their signalling points in a technical 
form. It is primarily intended for system configuration and maintenance.

The technical tree can include the following objects:

• Devices/next devices

11 10/2014 | revision: 1.2 | Printed in Germany



GEMOS4 operator manual Master data

• Reporting points

• Web clients (workstations that are logged into the system are also automatically set up as 
"devices" and equipped with detectors which can provide information on the status of the 
workstation)

• Operator – all users that have logged into the GEMOS at any time are created here 
automatically. These reporting points provide information on the login status of the user

The devices and detectors can be configured in two ways: firstly, it is possible for the device to be 
integrated into the system via the interface. Each device and detector object is predefined via the relevant 
interface and contains all the necessary information (operating elements, possible signalling statuses and 
switching instructions). The relevant installer is responsible for configuring the device (e.g. burglar alarm 
system) in the technical view (see manual for installers). Knowledge of the details of the interface and 
corresponding log generation is therefore not required for project planning.

The second way is to enter devices and detectors manually. This version is used if, for example, the system
software is to be prepared without installing the hardware. In this case, a detailed list of the planned device 
configurations must be available. Manual entry should only be carried out by users that have already 
acquired experience with devices and detectors operating under GEMOS.

Figure 2.2: Technical View

Technical data (devices/detectors) is processed via: Master data > Technical view (create or select 
device/detector).

2.1.1 Devices

A device represents a subsystem which is connected to GEMOS. Each device monitors and administers 
several detectors. These are in the case of detection line cards, for example, the 16 detection lines, 2 
relays and the fault or sabotage monitoring systems of the card. With central interface cards, the 
information is based on the data provided by the alarm system.

2.1.1.1 Creating devices

Devices are created via: Master data > Technical view

Click the Technical view link right at the top of the hierarchy tree (it will then be highlighted in blue). The 
screen in which a device is created contains the following tabs: Folder, Links, Access rights, History.
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Figure 2.3: Create a new device

The following entries are possible in the Folder tab:

Add

Device: create device via Add  after entering the device ID in the input field 
("dev_enet" for an Esser fire alarm system is shown in the illustration as an 
example)

The input mask on the right-hand side of the screen then changes and the newly created device can be 
configured (see Figure 2.4)

Designation Plain text designation of device as displayed to the operating personnel. 
Although descriptions can be several lines in length, only the first line entered is 
displayed at many points in GEMOS for space-saving reasons. In order to be 
able to identify the device, the first line should contain the most important 
information whenever possible.

Type Type of interface program

Statistics Display of incorporated reporting points 

It is possible to add further devices or detectors below the device which has just been set up

Add

Device: To create a device go to Add  and enter device ID (e.g. subordinate alarm 
systems)

Reporting point: Create reporting points via Add  accompanied by entry of area ID
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Figure 2.4: Configuration of a new device

A list of the links created (alarm location plans, measures plans, etc.), a list of rights and the corresponding 
technical history is displayed under the Links, Access rights and History tabs respectively.

2.1.1.2 Interface documentation

If a type has already been assigned to the device, a new tab Interface documentation appears in which 
information on the connected subsystem, system requirements, log, version statuses, usable detector 
types. etc. is displayed.

Figure 2.5: Interface documentation

2.1.1.3 Deleting a device

Select the device to be removed from the tree structure on the left. Devices cannot be deleted if 
detectors/lines are still entered for this device. All links of the device to be removed must be deleted 
beforehand.

When you delete a device, the messages in the log that originated from this device will 
automatically no longer be assigned accordingly in the log. The same applies for existing 
messages in the log.
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2.1.2 Detectors

Reporting points represent the sensors of an alarm system in the technical view. These can be physical 
detectors in the facility and also virtual detectors that display system states or different statuses. As is the 
case with the devices, detectors can be created automatically when commissioning an interface 
(depending on the interface used), when the message is received or manually in the master data.

2.1.2.1 Creating a detector

Click the reporting point in the technical view at the corresponding point (depending on the device and 
structure) in the hierarchy tree below which the new reporting point is to be created.

Add reporting point 
Sub-detector:

Create detector via Add accompanied by entry of detector ID

Pro02-ID Unique (technical) ID of detector. The Pro02-ID cannot be edited and has the 
following structure: »[:«subdevice»]/«function»[:«subgroup»]:«detector»

Ext-ID External ID for link in external databases. This can (but does not have to be!) an 
AKS key. The field is activated when importing data and cannot be changed 
manually.

Status Current status of detector.
ATTENTION: the status is a snap-shot and is not updated automatically in the 
master data! Click  to update manually.

Click  to delete the status of the detector.

Designation Plain text designation of the detector, as displayed to the operating personnel. 
Although the description can be several lines long, for space reasons only the 
first line is displayed at many points in GEMOS. In order therefore to be able to 
identify the detector, important information should whenever possible appear in 
the first line.

Location code An additional (formalised but human-readable) location code can be entered 
here.

Detector type Type of detector. The detector type essentially determines which commands the 
detector receives and which messages it can transmit. The detector type is NOT
the symbol that appears in the location plan!

Symbol Standard symbol used to display the detector in the location plans.
ATTENTION: a different symbol may be defined in the individual location plan. 
The setting made here is then remains ineffective for this plan.

An existing detector can be changed via: Master data > Technical view > Select device (tree view) > Select 
detector (tree view).
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Figure 2.6: Create detector

2.1.2.2 Deleting a detector

To delete a detector, it must be called up in the technical view.

It will not be possible to delete detectors if:

• they can be called up directly in measures plans in an additional or alternative condition.

• they are activated as part of an individual measure within the scope of a measures plan

• they are linked to location or measures plans

• they are the destination of a special link

• have sub-detectors

Measures and location plans would remain saved in a condition which is not easily reproducible if the 
deletion of a relevant detector of this kind were allowed. In this cases, the relevant links must first be 
deleted with the other master data.

2.1.2.3 Linking detectors

It is possible to link an extremely wide variety of data when processing master data. Technical data 
(devices/detectors), location plans, measures plans, documents, etc. can thus be combined. Links are 
displayed after clicking on Links or can be added there. By clicking the mouse on the linked data set you 
can switch to it, make corresponding entries and, if necessary, subsequently return to where you started.

Figure 2.7: Linking detectors
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Example: A detector is to be linked to a location plan

This is selected via: Master data > Technical view (tree view) > Select required detector (the corresponding 
information for the detector is displayed) > Links (possible link areas are displayed) > Selection location 
plan in the alarm location plans area (link is created via the tree structure which can be called up via the 
green Plus symbol).

Once all the required link destinations have been selected, press the Save symbol  to store the changes
to the master data permanently.

2.2 Hierarchy/Layout

The hierarchy allows the operating personnel to take a structured approach to preparing the facility 
according to location hierarchy (storeys, buildings, etc. displayed separately) or administration hierarchy 
(subsystems displayed separately). The folders Location hierarchy and Administration hierarchy are 
normally at the highest level. These folders can be renamed, or extended if required at the same level 
using additional folders (e.g. folder for start location plans, virtual monitors, ...).

The location hierarchy comprises the main navigation based on the building architecture and/or the 
geographic location.

The Location hierarchy folder normally contains subfolders for the various locations. These contain the 
building (parts) which contain the individual storeys inside which are the location plans.

The administration hierarchy makes it possible to structure parts of the facility based on their organisational
assignment. Although the primary purpose of the administration hierarchy is to assign access rights, it can 
also be used for navigation. The "Clients" folder normally contains subfolders for the individual clients which
contain links in the location hierarchy.

Figure 2.8: Example of hierarchy

The location plans are the central component of the GEMOS 4 user interface. They schematically 
represent the project being monitored and the signalling technology used in the operating program.

A location plan can contain the following elements:

• Drawing of floor plan or photographic representation of project under surveillance

• Detector symbols that depict the position and current status of the individual detectors in the 
alarm system

• Buttons that trigger specified actions when pressed. This can be a change of screen display, a 
switching operation or the initiation of a measure

• Explanatory drawings and texts

A change from the location plan to the user interface can be triggered by
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• the acceptance of a message in the alarm stack

• operator-defined buttons in the location plan

• use of navigation bars or hierarchy trees

All location plans are stored in a structured manner in the Hierarchy folder and its subfolders. If required, 
additional subfolders can be created.

The content of the Hierarchy folder is visible in the user interface and is freely configurable under Master 
data. All other elements of the hierarchy tree are only displayed in the Master data section.

A layout, folder or measures plan can be created at any point within the hierarchy by clicking on the 
relevant button (see Figure 2.9) then "filled with meaningful content", if necessary.

2.2.1 Folder

New folders are created in order to simulate the structure of a facility (e.g. when a building/storey/... is 
added): Master data > Hierarchy/Layouts > Location hierarchy > Folder (any designation can be selected)

Figure 2.9: Creating folders

Designation: Enter folder name 

Sorting sequence 
(within navigation bars)

empty=alphabetic
0=plan/folder to be loaded as preference
1...n =order within buttons of a dynamic
navigation bar (negative numbers possible)
up to 999=disabled in the navigation bar

Content/Search: Search in master data tree

A list of the links created (alarm location plans, measures plans, etc.), a list of the rights and corresponding 
technical history is displayed under the Links, Access rights and History tabs respectively.

2.2.2 Measures plan

A measures plan can be created here via: Master data > Hierarchy/Layouts > Location hierarchy > Folder >
Measures (any designation is possible).

Measures plans should only be created here in exceptional cases. It may be necessary, for 
example, to prepare measures plans separately for each building. Otherwise in the interest of 
maintaining a clear overview, measures plans should be created under Master data > 
Measures (plans).

For detailed information on creating measures and measures plans, refer to the chapter "Measures 
plan(s)".
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Figure 2.10: Creating a measures plan

2.2.3 Layout

To create a location plan, go to: Master data > Hierarchy/Layouts > Location hierarchy > Folder > Layout 
(any designation is possible).

GEMOS owes its flexibility for the most part to the nature of the layouts. Operating elements, detector 
symbols and graphics can be freely positioned.

These can be used for "normal" presentation of image contents (reporting points, graphics, buttons, …) and
also for CAD drawings incl. layer display.

The layouts are loaded at the user interface in predefined panes (frames). The division of the screen into 
frames is defined by what is referred to as framesets which are created via the menu function "Basic 
configuration->Framesets".

Designation: plain text designation of layout as displayed to the operating personnel. 
Although the description can be several lines in length, only the first line is
displayed in lists. For identification purposes therefore, important 
information should whenever possible appear in the first line.

Sorting sequence
(in navigation bars):

empty=alphabetical
0=plan/folder to be loaded as priority
1...n =sequence within the buttons of a dynamic navigation bar (negative 
numbers possible)
999=disabled in the navigation bar

Target frame: Selection of frame in which the location plan should be displayed hidden 
(set as basic value), all frames from all framesets are displayed, e.g.
Frame1 here: graphic frame
Frame2 additional frame
…
[hidden] no display
[new window] new window
[whole window] whole window

Display as: specifies the display mode:
HTML static - static display the size of which cannot be changed, e.g. for 
gif, jpg and pdf files
HTML zoomable – variable display. The zoom factor is initially adapted 
automatically to the frame and can be changed by the user - for dwg files
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Link as alarm location plan: If marked with a cross, this location plan is linked automatically as an 
alarm location plan for all detectors it contains

In the event of an alarm:
Detector centred

In the event of an alarm, the triggered detector is displayed centrally

Do not hide other detectors In the event of an alarm, the detectors that have not been triggered also 
continue to be displayed if this has been disabled for the entire system in 
the basic configuration. The triggered detector is highlighted.

Print automatically In the event of an alarm, this location plan is printed automatically.

Print if requested A print button is displayed for this location plan.

The location plan editor can be used with the following buttons at the bottom on the right:

Delete Deletes the input

Test Displays the layout for the test in the operator control view

Edit Calls up the layout editor in which the layout/location plan can be edited.
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2.2.4 Administration hierarchy

The administration hierarchy is structured in the same manner as a location hierarchy.

Figure 2.11: New location plan layout 

2.2.5 Editing location plan in GEMOS visualisation editor

The location plan editor is an integrated fully web-enabled editor. The location plans are generated by the 
GEMOS server interactively for signal processing from the database contents based on the coordinates of 
the signal point.

To edit the location plan go to: Master data >  Hierarchy/Layouts > Location hierarchy > Folder  > Layout > 
Edit

Figure 2.12: New location plan in the editor

If a frame has already been selected for this layout under "target frame", the xy dimensions of the frame 
boundaries are then displayed as fine broken lines (also several times if present in different framesets) for 
clarity of overview.

2.2.5.1 Editing of layout elements

2.2.5.1.1 Selection of elements

Click one element to select this element (only). To select several elements at once, hold the left-hand 
mouse button down and drag the mouse to open a rectangle; all elements that are completely inside this 
rectangle are selected.
Hold the Shift button down during a selection operation to deselect the newly selected elements and 
retain all other selections. Individual elements can thus be added to or removed from the selection.
Additional selection functions can be found in the "Selection" menu item in the layout editor menu bar.
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2.2.5.1.2 Displacing and changing the size of elements with the mouse

To start the displacement operation, click the selection box and move the mouse holding the mouse button 
pressed down.
To change the size (scale), click on one of the handles on the boundary of the selection box and drag the 
mouse with the mouse button held down. The scaling is normally proportional, i.e. the ratio of sides of the 
selected elements is retained. It is possible to override this by holding the Alt button pressed down.
When moving or rescaling, the selection locks onto grids and existing help lines. You can override this by 
holding the Ctrl button pressed down when dragging the mouse.

2.2.5.2 Layout tools

The layout tools on the top right-hand side of the visualisation editor are displayed in conjunction with the 
Edit elements, Insert and Levels tabs.

2.2.5.2.1 Insert

Click the Insert tab to add the following elements to the location plan:

• graphics from the Hierarchy and Import folders,

• detectors from the technical view,

• detector areas,

• additional texts, buttons, dynamic elements and other elements.

Figure 2.13: Layout Tools

Once inserted as an element in the layout, different characteristics of this element can be edited via the 
Edit elements tab. To so, initially select the required element once as the active element by clicking the 
mouse on it in the layout editor or selecting it from the drop-down menu in the tool window.

The following characteristics can be defined here:

Position and size of element in x/y coordinates and pixels.

If this is a reporting point, also the text (without, one or several lines), the position of the text (right, left, top, 
bottom) and the detector symbol to be used. If a symbol is not selected here, the symbol stored in the 
master data for this detector is used, otherwise the one selected here will be used.

Changes that have not yet been saved are displayed in the bottom margin. Click on the "Save" symbol to 
apply the changes and adapt the characteristics of the selected object.
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Figure 2.14: Characteristics of a reporting point in the layout editor 

2.2.5.2.2 Levels

The level functions, level options and actions can be found under the Levels tab.

Creating a level: enter a unique name in the empty input field, select the required function under Function; 
the level is immediately added and appears alongside the existing levels in the correct alphabetical order.

Delete level: click on the red cross to the right of the level which is no longer required (to be able to do this 
there must be no elements at this level). The level will only be deleted permanently from the list of usable 
levels once the Save symbol has been pressed.

2.2.5.2.3 Level functions

Each level has a function. This controls which elements can be placed at the relevant level, the order in 
which the levels overlap and how the level behaves in operating mode.
The following functions are available:

Original symbols The level contains original symbols from the CAD import and can be displayed 
in the editor if required for verification purposes.

Detectors The level contains detector symbols.

Undefined The level does not have a special function.

Operating elements The level contains operating elements (buttons, etc.).

Views The level contains partial images which can be selected by the user. It can be 
selected in the editor if required, but is not visible to the user.

Detail The level contains additional details that can be displayed if required via the 
floor plan.

Floor plan The level contains a drawing of the floor plan or a comparable background.

Fill The level contains coloured fills that appear behind the floor plan.
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2.2.5.2.4 Level options

The following options are available for each level:

 The level is visible in operator control mode.

The level can be displayed/hidden by the user

 The level is not visible in the editor

The level is visible in the editor but is locked

 Elements at the level can be viewed but not modified

 Elements can be edited

2.2.5.2.5 Actions

 Unlock imported level for reworking

 Delete level

 Apply modified level settings

2.2.6 Layout elements

2.2.6.1 Text/Text box

Explanatory texts can be created directly in the location plan. Click the Text/Text box button (under Insert 
tab). The element properties are displayed on the left-hand side of the screen. The text field appears in the 
location plan.

Selection Select a text or a text box, if several text elements are available, the first 20 
characters are also displayed in order to be able to quickly differentiate between
them

Position and size: x, y coordinates of the top left-hand corner of the text and information on height 
and width in pixels, press  to apply the settings

Text: Input field for display text

Style: Dropdown menu for defined font styles

Figure 2.15: “Text” editor element for location plans
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2.2.6.2 Button

Buttons are areas located within the location plan which can be clicked with the mouse and trigger 
permanently defined actions. These can, for example, be a change of screen display, a switching operation,
a message or calling up a web page. Buttons can respond to changes in the detector status using different 
background images, graphics, symbols, icons, or colour change via css.

A button is inserted in the layout editor via Tools > Insert > Button. The element properties open on the left-
hand side of the screen. The button to be defined (blue rectangle) appears in the location plan.

Position and size: x, y coordinates of the top left-hand corner of the button and width and height in 
pixels, press  to apply the settings

Reference detector: default (none), allows a reference detector to be selected from the technical 
view to which an appropriate visual response is given based on its status and to 
which switching commands can be delivered

Template: The template that defines how the button should respond to the reference 
detector is selected here. Templates can be prepared intuitively under Basic 
configuration > Templates > Templates: Visualisation > Button/Hatching styles.

Display/Actions: List of commands: Display of defined element properties
Script mode: a wide range of settings can be generated here using a script 
(programming knowledge required).

Elements in the command list can be edited by clicking on them then modifying the properties (e.g. change 
text, replace background image, change destination for commands, ...)

To add an action to the list of commands, click on the action below which the new action is to be inserted 
then select the new element from a range of options.

The following options are available:

Show layout: Displays an object: the location plan to be loaded can be selected in the tree 
from inside areas, hierarchy and technical view or via special links relative to the
workstation/triggering detector. If the destination is a detector, the location plan 
which is linked to the detector will be displayed

Text: Input of text, language can be set

Font style: Setting of font style

Button style: Selection of background image for the button above the selection field.
Basic types "Standard" (=normal button), "Command" (=command to a 
subsystem) and "Active" (=active state) are also used in operator control panels 
and the master data.
Simple:
These buttons have been optimised so that they can also be correctly displayed 
in older browsers (Internet Explorer 8).
GEMOS:
These buttons have an appealing basic design but require an up-to-date (CSS3-
compatible) browser.
Project-specific:
These buttons can be created for specific projects in the Theme Editor based on
any CSS3 attributes.
Bitmap:
These buttons use a background image (png, jpg, gif) from the "data/buttons" 
folder as the basis. As their size can only be scaled to a very limited extent and 
a confusing variety of background images quickly accumulates, they should only
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be used in exceptional circumstances.

Send command: Assignment of a command to a reporting point which is to be switched. 
Detectors can be located and selected via "Select in tree" in the Areas, 
Hierarchy, Technical view folders or via special workstation-specific links. Select 
the required command from the "Command" menu. The additional data required 
for the triggering operation (e.g. camera number in the event of intrusion, etc.) 
can be entered in the "Parameters" menu. A value can also be entered in the 
"Value" field.

Additional elements Further actions are listed under Additional elements, sorted according to 
conditions, actions, display and navigation

Figure 2.16: “Button” location plan editor element

2.2.6.3 Dynamic element

Dynamic elements are similar to the Text/Text box layout element but have 2 additional properties:

Predefined objects exist (clocks, input fields, session data, ...). These can be selected via a selection box.
Further parameters, such as position and size, assignment to a detector and effects (similar to buttons), 
can be adjusted.

2.2.6.4 Additional elements

Further actions are listed in the dropdown list: frame, legend, hotkey/action when opening, view, panel, 
menu bar, help line, calculated image.

Frame:

Frames can be created directly in the location plan. A frame is inserted via: Master data > Hierarchy > 
Location hierarchy > Folder > Location plan > Edit > Tools > Insert > Frame. The element properties are 
displayed on the left-hand side of the screen. A frame appears in the location plan (yellow square), this 
must be defined. A new frame with size 100 pixels x 100 pixels is inserted.

Position and size x, y coordinates of top left-hand corner of the frame as well as information on 
width and height in pixels, the settings are applied with  

Frame Name (name of frame)
initial content
Frame (with or without frame)
Scrollbar (with or without scrollbar)
subsequent use (control panel or alarm processing)
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Legend:

A legend is inserted in the same way as a frame The element properties are displayed on the left-hand side
of the screen. A rectangle (predetermined width and height) appears in the location plan with information on
creation, date of revision, processor and version.

Actions when opening:

The actions to be performed when opening a location plan (e.g. initialising markers) can be defined. An 
action is inserted via: Master data > Hierarchy > Location hierarchy > Folder > Location plan > Edit > 
Actions when opening (add in the Element menu). The element properties are displayed on the left-hand 
side of the screen. An orange square that represents this action appears in the location plan (not displayed 
at the user interface and cannot be selected using the mouse pointer). The actions are selected as 
described under "Buttons".

Once all entries/changes have been made, the location plan must be saved via the File tab in the menu 
bar.

Save The plan is saved with no further prompts.

Close If changes have been made to the plan, a prompt will appear to ask whether 
they should be saved.

If a frame with the same name but different size is used in several framesets, the frameset for 
which this location plan is to be used must be specified when saving.

2.3 Measures plan(s)

Measures are the actions that must be initiated following an incoming alarm message in the GEMOS 
system. Any number of actions can be defined for each notification type or detector that have to be carried 
out in the event of an incoming alarm. They are combined in action plans then assigned to one or several 
detectors.

Once an individual measure has been created, this can be an integral part of different measures plans. Any
changes (e.g. to a telephone number) must then be carried out for that individual measure only and are 
adopted automatically in all measures plans.

To access measures and measures plans, go to Master data > Measures plan(s).

Figure 2.17: Measures/Measures plans

2.3.1 Individual measures

Individual measures are processes that are carried out on a step-by-step basis within the management 
system when executing automatic functions and processing alarms They are incorporated into measures 
plans and can therefore be combined to create complex macros or scripts.

Results that reflect the success or lack of success of the measure (achieved/not achieved, switching 
command performed/implementation failed, etc.) are predefined for each manual measure. The user must 
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normally select one of these results during processing before he can proceed to the next measure. The 
subsequent processing path can then in turn be derived in the measures plan based on the successful or 
unsuccessful implementation of a measure. This means for example that the predefined result "Spurious 
alarm" can lead to the processing being cancelled and an appropriately labelled entry in the notification 
report. Also if an attempt to reach a contact partner is unsuccessful, an alternative telephone number or 
another contact partner can consequently be called up. The operator can enter his own optional comment 
for each measure which is saved in the long-term report.

Automatic measures require no interaction with the user and are performed by the system (example: close 
roll-up door, swivel and connect camera, …) Automatic measures can be configured in relation to the time 
of implementation and can for example be implemented in the event of an incoming notification, receipt of a
notification and completion of a notification, and so on.

message arrive

display of the proposed  
measures

display of possible results 

eg. "success" or "no success"

(different results depending
on the measure can
be specified)

measure was successful,
message will been completed,
the entire action will be logged
labelling in the alarm stack

execution of the proposed
measure 

selecting the message

clicking the measure 

entering the appropriate
result eg. "success"
comments can be entered

additional messages can
be edited

editing is aborted
later editing follow again

measure was not successful,
message will not been
completed,
re-processing is necessary, 

labelling in the alarm stack
the entire action will be logged,

Figure 2.18: Flow chart for a measure

2.3.1.1 Types of individual measures

Individual measures can be generated in GEMOS in different ways, depending on the type of measure:

• by manual input => type manual handling instructions

• by macro input => type command list

• by GMH script input => type script

To insert a measure: Master data > Measures/plans > Folder (for clearer overview) > Individual measure 
then enter parameters. To change an individual measure: Master data > Measures/plans > Folder > select 
and change corresponding measure.
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Figure 2.19: New individual measure

Designation Entry of name (default = new)

Link Link the installation sites

Access rights Display of access rights

History Report for creation/change of individual measure

Manual handling instructions Handling instructions for the user

List of commands Switching instructions, rights enquiries, calling up layouts, ...

Script Option for programming measures in gmh

2.3.1.2 Individual measures type "Manual handling instructions" (manual measure)

Manual measures are measures that must be taken by the user. In this instance, the operator of the facility 
has the option of specifying the actions the user must take and provides a selection of possible results. The
user must provide a result to confirm that the measure has been carried out correctly.

Measures can be pooled with alternative measures only ONE of which must be processed, e.g. print/do not
print location plan. Once processing of the signal has started, one option can be selected from all available 
options displayed. The measure is considered to have been successfully completed if one of the options 
has been selected.
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Figure 2.20: Manual measure

Designation: Enter the name of the measure here

Manual handling instructions Enter the handling instructions here manually

Selectable results Enter the possible results here in text form

2.3.1.3 Individual measures type "List of commands"

The individual measures type "List of commands" can be an automatic individual measure or a switching 
and control measure.

2.3.1.3.1 Automatic individual measure

Automatic measures are performed by GEMOS automatically as soon as the operator of the facility assigns
a specific notification to them. These are normally switching commands to devices that are to be activated 
as the result of an incoming notification. An automatic measure can however also be, for example, to print 
out a location plan as directions for the fire brigade.

Measures to be carried out automatically are displayed in the measures plan but are not displayed when 
processing alarms.

2.3.1.3.2 Switching and control measures

The switching and control measures have a similar purpose to the automatic measures, namely to activate 
the devices connected to the GEMOS system. In contrast to the automatic version, GEMOS expects the 
devices to be triggered explicitly by the user of the program.
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This type of measure is primarily used in situations where the consequences would be far reaching if the 
device function were triggered, and triggering due to a fault in the system would pose too high a risk. For 
example, the activation of a sprinkler system in a computer centre would only be triggered if the signal from
a smoke detector was verified by the operating personnel.

If the measure was unsuccessful, the switching command is also executed again at the next 
attempt.

In order to provide the user with an overview of the entire processing operation, switching and control 
measures also appear in the measures plan. It is not normally necessary to select a result with these 
measures, and are instead only marked with a checkmark.

Switching and control commands without further input are triggered by selecting the measure. 
Although a window does not subsequently open, the text for the measure now appears scored
out and is marked with a checkmark. If it is still necessary to be able to select a result, this 
must be configured under "selectable results".

Figure 2.21: List of commands

Designation: Enter the name of the measure here

Insert: All input parameters are displayed in a selection box via which additional 
functions/conditions can be inserted. The descriptions of the individual 
functions that can be selected in this case are explained in the chapter 
"Measures/plans".

Selectable results Enter the possible results here in text form
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2.3.1.4 Individual measures type "Script"

The individual measures type "Script" can be the type "Automatic individual measure" or the type 
"Switching and control measures".

Figure 2.22: Script mode (expert mode)

Designation: Enter the name of the measure, this can be anything

Script In script mode, GEMOS can generate an extremely wide range of individual 
measures using GMH script (programming knowledge is required). The 
command lines are entered in the form of a GMH statement.

Selectable results Enter the possible results in text form

2.3.2 Measures plans

Measures plans are measures that are collectively assigned to a notification. They control the behaviour of 
GEMOS after a notification arrives. The measures plan to be used for the respective detector is defined in 
the device/detector master data.

Measures plans can be triggered manually via a button, by a change in status of a detector or by a time 
control. In this case combinations of the triggering events with mutual dependencies are also possible.

Separate measures can be defined in the measures plan for each event that could potentially be reported 
(alarm signal, arming signal, fault, etc.). In addition, the measures selected can still depend on the 
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conditions. These can (among others) be the armed state of the detector itself, the armed state of the 
facility, the locking status of the block lock assigned to the detector or the statuses of other detection lines 
of the same or another alarm system.

Depending on the size of the facility, the same measures plans can always be followed for signals from 
different devices (e.g. if smoke detectors have been installed at different locations in the building, the same 
steps are always carried out in the event of an alarm).

Conditions signal the status of the connected system in a similar manner to events. However, events are 
reported to GEMOS while conditions are status checks that are carried out via GEMOS. With a condition, a
check is normally carried out, for example, to determine whether the triggering detector was in the relevant 
state at the time the signal arrived (or to be more precise: directly before the signal arrived).

Apparently conflicting events and conditions can also be created. This of course means that 
the event "Arming signal" can be linked to the condition "Detector unarmed", for example. 
Repeat signals can be detected in this manner and handled accordingly.

Both the "event" and also the "condition" in the measures plan serve to trigger measures in the form "IF 
<event or condition> THEN <action1>OTHERWISE<action2>.

Conditions can be logically linked. It is also possible that ALL or only one of the conditions must apply for 
the measures to be performed.

To insert a measures plan, go to: Master data > Measures (plans) > Folder (for a clearer overview) > 
Measures plan and enter the parameters. It is also possible to change the plan in the same place and apply
these changes in the system by clicking the Save button.

To delete a measures plan, it must be selected from the list. Measures plans to which there is a reference 
from a detector data set cannot be deleted.

2.3.2.1 Measures plan type "Decision-making tree"

The decision principle "Decision-making tree" is an If-Then editor and provides the option, depending on 
the event, of performing one or several actions.

Figure 2.23: Measures plan type “Decision-making tree”, example based on burglary

Designation Entry of name (default = new)

Valid for detector class(es): Assignment of predefined classes, e.g. intruder sensor or no classes

Signal pooling: Provides the option of pooling the same signals

Decision-making tree If-Then editor with several selectable events
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The starting point is a triggering signal (event). Different events can be assigned to the measures via the 
Alternative button. Each event must be evaluated and is selected from a list of possible events.

2.3.2.1.1 Event

In order to trigger a measures plan, a specific event is necessary. The relevant event (alarm, signal) to be 
signalled by the triggering detector or device is selected from a list. For clarity of overview, the different 
events are categorised according to status groups.

It is possible to define several events for the same measures to be performed via the Alternative button.

Figure 2.24: List of events
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Figure 2.25: Time of implementation of a measure

2.3.2.1.2 Insert elements in the measures plan

Once an event has been entered and optional detector conditions have also been entered, the required 
measures must be entered in the necessary sequence.

The most frequently inserted commands are available as buttons. Further elements can also be selected 
via the selection box. The following selection options are available, depending on which license has been 
obtained:
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Figure 2.26: Detector action

2.3.2.1.3 Conditions

Status amendment Additional status information for a triggering detector (e.g. "currently is", "was 
when signal arrived")

Detector status Requests the status of a detector. This can be the triggering detector, any other 
detector or a specially-linked detector.

Check marker Requests the content of a marker to check for conformity. To do so, the name of 
the marker must be entered in the "Name" text box and a string must be entered
in the "Value" text box. Alternatives are also possible here.

Check session status Check for session status (user, user group, workstation, etc.)

2.3.2.1.4 Actions

Apply markers Markers can be set once an event has occurred using this action function. To do
so, the name of the marker must be entered in the "Name" text field and a value 
must be entered in the "Value" text field.

Cancel signal Signals (e.g. shutdown signals) can be cancelled without the signal having to be
completed, if the detector is switched back on for example. To do so, the alarm 
must not have been accepted.
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Apply operator station  This action assigns the event that occurs to a workstation (web client). The 
required workstation must be selected from the selection menu. Each web client
that logs into the system is added automatically to the selection list.

Set priority This action can be used to set a priority for the event that occurs. Select the 
required priority level (e.g. high) from the selection menu. The priorities can be 
defined in the Master data > Basic configuration / >Master data configuration > 
Signalling priorities menu

Apply signalling location The incoming result can be assigned to a signalling location with this action 
function.

Logging Logs the event in a log of your own choice (signalling log for example). This is 
only necessary if the measures plan does NOT contain a manual measure

Set category This action assigns an incoming event to a category. Select the required 
category from the selection menu (e.g. emergency calls). The categories can be
defined in the Master data > Basic configuration> Signal processing menu 

Measure Calls up a measure for editing (manual or automatic). The time of execution can 
be configured for automatic measures

Trigger signal With this action function, signals are triggered following an incoming event. 
Parameters are entered as described under Send command.

Send command With this action function, commands can be sent to specific detectors once an 
event has occurred.

2.3.2.1.5 View

Text Displays a text (e.g. information) for the user for alarm processing.

2.3.2.2 Measures plan type "Script"

A measures plan can be prepared using gmh script in script mode (programming knowledge required). 
Select the Script type from the measures plan type selection list. Command lines can be entered in the 
input field in the form of a GMH statement.

Designation Entry of name (default = new)

Valid for detector 
class(es):

Assignment of predefined classes, e.g. intruder sensor or no classes

Signal pooling: Provides the option of pooling the same signals

Script In script mode, GEMOS can generate a wide range of measures using the GMH
script (programming knowledge required). The command lines are entered in 
the form of a GMH statement.

You can switch between the Script and Decision-making tree measures plan types.
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Figure 2.27: “Script” measure plan

2.4 Data import

The data import acts as the interface between drawings, documents and tables provided by an external 
source as well as GEMOS.
It performs the following functions:

• Organisation of documents in folders.

• Prevents documents that are modified at the source from being visible to the user (guards) 
immediately before they are checked. Revised documents are only visible once they have 
been imported explicitly by one master data administrator.

• Starting point for the CAD-Import.

The following file formats are possible for the data import in GEMOS:

pdf file Use in GEMOS visualisation editor (Acrobat Reader must be installed).

gif file / jpg file Use in GEMOS visualisation editor. When creating gif/jpg files, bear in mind that 
when the image is scaled (enlarged, reduced) this significantly affects the quality
of the image.

dwg files For use in GEMOS visualisation editor (HTML zoomable). The dwg files are 
imported directly. The layers can be displayed depending on the import settings. 
The GEMOS detector symbols are activated on this plan. The dwg files must be 
prepared according to the CAD import requirements (for preparation see manual
"Prerequisites for CAD-Import_GEMOS").

The file names must not contain blanks and special characters1

csv file Assignment tables, e.g. for positioning the detector on the location plan when 
using dwg files. The requirements for these files are described at the import 
functions).
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svg file For use in HTML location plan editor, if the SVGs are imported as images (from 
Internet Explorer 9, Firefox 4). svg files can be scaled (contain "viewbox" 
attribute)

cadcfg files Template files for import of detector from dwg files. These files are stored in the 
"Data import" folder automatically when saved during the CAD import.

2.4.1 Graphic import

All necessary data required for the user interface is administered in the data import folder Master data > 
Data import > Import folder (tree view). Graphics can be edited in a wide range of graphic or CAD programs
then copied to the import folder, the graphic formats *.gif, *.pdf, *.jpg, *.dwg and *.svg (as image) are 
currently recognised.

Press the Folder button to create a new subfolder. To create more subfolders in an existing folder, mark the
corresponding folder in the tree view and press Folder in the "Add" pull-down menu. 

Figure 2.28: Import folder

Designation Name of folder. If the box next to "Standard path" is checked, the designation of 
the folder will be adopted as the file name. Please use valid characters for this!

File path Path of corresponding folder on the plate.

Please use only valid characters for the file names! The characters ":", "/" and "\" have a 
special meaning, depending on the operating system. Commas must not be used. In addition, 
language-specific special characters can also cause problems with Windows systems.

Additional subfolders within import folders must be created, renamed or deleted exclusively in 
the master data interface (Folder) button. Changes made using the options provided with the 
operating system are not recognised by the pro02 server and may lead to loss of data.

The files can be uploaded from a data medium (hard drives, diskettes, CD-ROMs, etc.) to the import folder 
of the GEMOS system. To load files from a local disk, press the Upload file(s) button then select the 
corresponding file via Browse. Press OK to start loading. The operation can be cancelled if required.

The files can also be copied from GEMOS directly to the "import" directory (or corresponding 
folder in the "import" directory) using the Explorer.

All importable, non-importable, missing, newly copied or modified files (a file of the same name must 
already exist) are listed in the import folder in the "Content/Search" pull-down menu (several selection 
settings can be specified). This is updated via Import selection or Import all. During updating, the files in the
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import folder are incorporated into the database. This prevents the original files from being accidentally 
overwritten. Documents are edited and used in the same manner. The Designation field is freely definable. 
The path is displayed.

Figure 2.29: Uploading files

2.4.1.1 CAD import of dwg files

dwg files are imported into the location plan via Data import > Import folder > Folder > CAD/CSV import. 
This button is only displayed if there are dwg files in the corresponding folder.

Figure 2.30: CAD import of dwg files

The following actions can also be carried out here in preparation:

Import selection Imports the file(s) previously selected in the list.
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Import all Imports all files displayed in the list

Add... Folder Adds a subfolder

Upload files Opens a dialogue for uploading files from the workstation to the server.

Content/Search Displays the images/documents in the folder. The following filters can be 
selected:

New/modified files Only displays files that have changed in the file system and must be reimported 
into GEMOS.

All imported files Shows all files that can be imported.

Non-importable files Shows all files that exist in the file system but cannot be imported.

Missing files Shows files that have already been imported but are no longer available in the 
file system.

To start the actual CAD import, click CAD import.

CAD/CSV import Imports AUTOCAD drawings or CSV files.

This function is only required if meta information (detector symbols, detector lists) or complex drawings with
several levels are to be imported. Simple drawings can be inserted as an image into any desired location 
plan directly following the import.

The CAD import comprises several steps.

2.4.1.1.1 Step 1: selection of data

The files to be imported are selected here ("Selection" column). Templates can be previewed and selected.

Several files with identical import settings can be imported together. During this process, each file becomes
an independent GEMOS location plan. It is advisable always to import files with a similar level structure 
(dwg import) or column arrangement (csv import) as otherwise the settings become unnecessarily complex.

If several drawings are to be combined into one location plan, these must be assembled beforehand in a 
suitable editor (e.g. Autocad for dwg files, Exel for csv files). References can also be used here. 
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Figure 2.31: CAD import of dwg files – step 1

2.4.1.1.2 Step 2: assignment of levels

The levels (in the CAD plan these are the layers that have been created) that should be displayed in 
GEMOS or included in the location plan of the hierarchy are assigned during this step.

Example:

Layer name in the 
drawing

Function in GEMOS (explanations in italics)

BMA Detector (a layer is provided for the detectors)

Walls Floor plan (displayed as floor plan in the layout)

Doors Floor plan (displayed in layout as floor plan)

Room description Detail (displayed in layout as details that can be displayed/hidden)

Symbols_VdS always visible

necessary if these layers exist in the detector blocks (e.g. block symbol of a 
smoke detector is in the "Symbols_VdS" layer, this block was placed in the 
"BMA" layer in the technical plan

Dimensions leave empty (should not be displayed in GEMOS)

Layer names that have been used in the CAD plan can be renamed in the "Name in GEMOS" column. This
new name is then used in the layout editor and in the user interface.
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Figure 2.32: CAD import of dwg files – step 2

Different layers can be assigned the same name. The contents are then "added" to a layer. Example: 
original dwg layers BMA, BMA suspended ceiling and BMA false floor can be named BMA via "Name in 
GEMOS" and all detectors are then imported into the same layer.

For assistance on the import, refer to "Detailed step". The "Suggested layers for import" are displayed here.
Further options are "all layers", "all used layers" and "all visible layers".

2.4.1.1.3 Step 3: assignment rules

Assignment rules that establish a correlation between the blocks in the drawing and the detectors of a 
hazard alert system are prepared in this section. The detector can therefore be imported on the layer of the
location plan that corresponds to the item of equipment. Furthermore, the settings for display of symbols, 
possible correction of coordinates and so on are made here.

Example (see Figure 2.33):

Smoke detectors are located on the layer 456_GF_BTO_BMA_detector

Detector group in the CAD attribute "MELDER-GRUPPEN-NR" 0213/1

Pro02-ID could be as follows for example: dev_zettlerzx:1/M:213:1

The following procedure is recommended:
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Figure 2.33: CAD import of dwg files – step 3

1. Select the layer of the CAD drawing to be exported first.

2. Search for entries in the attribute "MELDER-GRUPPEN-NR" using the search pattern

3. Pro02Id is made up of the names and additional character strings (Pro02Id depends on the 
connected interface)

4. The CAD block of the smoke detector is displayed in GEMOS as the symbol sym_bma:rmo 
(this is assigned via a conversion table which can be created, opened and edited in this step)

Additional explanations:

456_GF_BTO_BMA_de
tector

Find everything on CAD layer 456_GF_BTO_BMA_detector

0(\d+)/(\d+) any given number prefixed by zero, any number of times, followed by a slash 
and any number, any number of times (Ex.: 0213/1)

dev_zettlerzx:1/M:$1:$2 create the Pro02Id using the attribute MELDER-GRUPPEN-NR of the CAD 
drawing in the form: dev_zettlerzx:1/M:number1 (before slash):number2 (after 
slash)

CAD:block replace the block symbol with the GEMOS symbol as specified in the table 
BMA-Symbole.csv (e.g. "optical smoke detector","sym_bma:rmo", saved as csv 
file)

The detectors must be entered in the CAD plans as blocks with attribute definitions according 
to the ela-soft specifications (see manual "Prerequisites-CAD-Import_GEMOS". It is advisable 
to assign presets to the CAD plan layers (layer visible and not visible) that are required in 
GEMOS as this saves time when editing.

Different versions can be listed via the filter, e.g. the wording of the designations in the attributes, whether a
Pro02Id could be compiled or which detectors were found.

2.4.1.1.4 Step 4: final information

The folder of the hierarchy in which the data is to be saved, how and where information is to be displayed, 
how large the symbols should be how the data is to be adopted in the GEMOS database is specified in the 
last step. This data entered can be saved in a template. Press Start import to perform the CAD import. 
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Figure 2.34: CAD import of dwg files – step 4

2.4.1.1.5 Step 5: start test run / perform import

The test run simulates the import. If performed correctly, step 5 will be displayed once again when the Back
button is pressed and the import can be performed.
Following the import, an overview of the imported data appears. To complete the import process, press the 
Finish button. The screen of the selected import folder reappears.

2.4.1.1.6 Result

• The detectors are stored on the imported layers in the hierarchy

• Further editing is possible, e.g. which layers should be visible in the user interface

• Additional layers/levels can be added and are retained when the import is performed again

• View windows can be defined, etc.

2.5 Software areas

Detectors can be grouped into areas. An area is symbolised by an area detector which can assume the 
different states of the detectors within an area.

Example:

Intruder sensors of an alarm system are assigned to different arming areas. When a detector triggers an 
alarm within an arming area, the area detector assumes the status Alarm.

An area detector can only display the first status change of the same type of triggering 
detector. The area detector cannot show all other detectors within the area with the same 
status change without having assumed the normal state again beforehand.

To create an area go to: Master data > Software areas. For clarity of overview, folders or several areas with
a hierarchical arrangement can be created. A character string can be entered in the input field which then 
forms part of the pro02id of the area. Blanks and special characters must NOT be used here. If the field is 
left empty when setting up an area, the next available iid for this object is used as part of the pro02id.

Any designation can be selected for the folder and the areas.
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Figure 2.35: Creating a new area (shown in example: _area/EIB:HausK)

Figure 2.36: Detectors within an area (see links in hierarchy tree)

Once an area has been added, the following settings can be made and partially edited:

Links Links, with location and measures plans among others

Access rights Display of access rights

History Display of editing log

Pro02-ID Display of area detectors assigned in the system (cannot be edited)

Status Display of status of area detector

Designation: Enter the name for the area here, any designation possible

Location code Location code of area (AKS code)

Type Display of detector type and class

Symbol Display of specified symbol set or assignment of a symbol set possible

Add: sub-detector Add a sub-area (any name possible)

2.6 User administration

To access the user administration go to: Master data > User administration

The basic configuration of users and groups and creation of new groups can also be carried 
out in the configuration of the Pro02 server (see chapter "System configuration“ of the installer
manual).
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Figure 2.37: User administration

2.6.1 Users

In addition to controlling access, the purpose of the user master data is to be able to assign different levels 
of access rights for the various parts of the system.

The options for processing the signal can for example be limited by defining access rights. Depending on 
the editing rights assigned, signals can always be terminated, or only terminated if the measures carried 
out were successful or if the alarm system is once again clear. The safety risks posed by signals that have 
been incorrectly processed either by accident or on purpose are therefore reduced.

The GEMOS system cannot be operated without logging in. The signal is however still 
processed.

To edit users go to: Master data > User administration > All valid users or administrators/users

Add users To create a new user, call up the input mask under "New users"

Figure 2.38: Assigning user data 

The following fields are available for input:

Log-in name Entered in the log-in mask when starting GEMOS

Full name Subsequently displayed in the GEMOS user interface and in the master data
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Password Enter password to log into the system

Please enter password 
again

Enter password again for security reasons

User blocked from/since Adjustable user time limit (optional)

Password expires on Period of validity of password can be adjusted – Format: DD.MM.YYYY

Dialogue language Select dialogue language here, e.g. German or English

User belongs to the groups Define assignment to group via buttons

Figure 2.39: Assigning groups

2.6.2 User groups

Users are assembled in groups and specific rights (read, write or configure) are assigned. There are no 
restrictions on which user groups can be created.

To edit user groups, go to: Master data > User administration. The corresponding user group can be 
selected for further processing here.

Figure 2.40: Editing rights for group
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Create new user group Press New User group then Rights (input screen appears immediately after the 
button is pressed)

The following input options exist:

Group name Enter the name of the user group here, can be changed at any time

Rights of the user group Rights are assigned/withdrawn using corresponding buttons; all assigned rights 
are listed

Additional rights (not 
assigned)

List of rights that can still be added (press corresponding  button)

Then click  save to assign the rights.

2.6.3 Assigning rights

The rights are assigned in 2 stages:

1. General rights are assigned under Master data > User administration

Answer to the question: WHAT may the user groups do?

The global rights, e.g. access to master data, user administration, access to modules such as GEMOS 
access (access control), are assigned here

2. Access rights "from the viewpoint" of the objects

Answer to the question: WHO can access this object?

These rights are inherited by objects lower down in the hierarchy. This applies both for the technical view 
and also the hierarchy/layouts.

If members of a user group are (not) supposed to see different location plans, the corresponding rights in 
the (local) hierarchy must be assigned. The same applies for the option of operating detectors. The editing 
rights from the viewpoint of the signalling points must be assigned here (editing in the sense of signal 
editing, not editing the master data).

Figure 2.41: Example for the editing of access rights

The user groups to which rights are to be assigned must initially be added manually.
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Analogous to this example, the access rights can be organised in an extremely wide range of input screens
within the scope of master data editing. Finally, click  to save the rights.

Figure 2.42: Example for processing of access rights with user groups

If specific modules cannot be displayed or processed, the assignment of rights must be 
checked.

2.7 Persons/Contacts

Persons and telephone numbers that have a specific function within the GEMOS system are recorded 
here. This can be persons with access rights and persons/companies that must be notified in the event of 
an alarm or fault.

Although, in terms of its structure, this database branch is similar to a telephone book, it must NOT be used
as such. Telephone books can be found in the separate menu bar Master data > Telephone books.

Figure 2.43: Persons/Contacts

All entries in conjunction with data of operators, installers, manufacturers and projects are made in the 
persons and contact module.
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To create addresses go to: Master data > Addresses/Contacts > Folder (for clearer overview), 
any designation possible.

A folder can only be deleted once all means of communication, addresses and companies have been 
deleted.

2.7.1 Creating companies

To create a company go to: Master data > Persons/Contacts > Company (any designation is possible).

A central data set is created at the same time as the new company which offers input options for address 
and communication data. One or several addresses can be added to companies that operate 
interregionally and have several subsidiaries via the "Add: postal address" button.

The contact form structures the information in the following contact groups:

Address: Title, name, street/no., postcode, town, country

Contacts: Telephone, mobile, e-mail, etc.

Further data: conversational language, comment

Figure 2.44: New company

Two areas are created automatically when setting up a new company:

New The company name to which further personal details are to be assigned is 
entered here, the address details of the company, as entered under 
Headquarters, are assigned automatically, a person is assigned via New Person

Headquarters The company name and address data, means of communication, etc. are 
entered here

To delete a company, all means of communication, followed by the addresses themselves must be deleted.
Once all addresses have been deleted, the company can also be deleted.
Once a company has been set up, the new employees are created via the Entry button under "Persons". 
Links between persons and companies can be made from 2 directions: the person can be linked to the 
company via the Links tab (with persons) then the company can be selected under Affiliation to 
companies/organisations or via the Links tab (with companies) followed by selection of persons/employees.
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2.7.2 Creating persons

To create a person go to: Master data > Persons/Contacts > select corresponding company > section for 
entering addresses of persons > New Person, (enter required data according to specified fields)

The contact form structures the information in the following contact groups:

Address: form of address, title, use company address, surname, first name, street/no., 
postcode, town, country

Contacts: Telephone, mobile, e-mail, etc.

Additional data: conversational language, date of birth, department, personal no., comment

Figure 2.45: Creating a new person

To change an address, follow the same procedure as you would when creating a new one. To delete an 
address, delete all subordinate entries and links first. The Delete button in the personal data input screen 
will only be visible and active once you have done this. You can also do this in the higher-level folder via 
the red cross.

2.8 Telephone books

Individual telephone books are managed here. When searching for a telephone number in the telephony 
panel, the search is performed in all telephone books for which access rights exist. Data therefore does not
have to be recorded twice! The telephone books can be accessed via Master data > Telephone books.

2.8.1 Organisations/Companies

The tree view with various submenus is displayed on the left-hand side of the working window. Click on the 
Organisations/Companies folder in the tree view to select a new or existing entry for a company in the 
telephone book.
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Figure 2.46: Company contacts

The information in the contact form is structured according to the following contact groups:

Address: form of address, name, name affix, street/no., postcode, town, country

Contacts: telephone, mobile, e-mail, etc.

Additional data: conversational language, comments

A field for a search designation is also located above the address.

2.8.2 Persons/Contacts

The tree view with various sub-menus is also displayed in the left-hand pane of the working window. Click 
on the folder "Persons/Contacts" in the tree view to select a new or existing entry in the telephone book for 
employees of a company. The contact form for persons is the same as the contact form for companies.

2.9 Overall tree

To access the overall tree, go to Master data > Overall tree. The tree view with various submenus opens in 
the left-hand pane of the working window.

Click a [+] symbol to expand the submenu below the term; various sub-items are displayed for selection. 
Click the [-] symbol to collapse the folder.

The hierarchy tree for the user can be freely configured by the system operator (with corresponding access
rights!). The operator can generate additional folders and subfolders himself.

To edit an entry in the hierarchy tree, click on the term itself. A corresponding window for the selected 
hierarchy tree object where data can be entered, modified, saved or deleted (depending on the level of 
authorisation) appears on the right-hand side of the screen.

Diverse information for the operator (buttons, folder) is displayed in a hierarchy tree on the left-hand section
of the screen:

To simplify the input of data, favourites, i.e. frequently used functional areas, can be individually combined 
and used to access these functions directly.

Create favourites Click the  symbol to create favourites.

Delete favourites Favourites can also be deleted individually in a similar manner to the links by 
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clicking the red cross next to the term.

To narrow down the search based on specific designations or data, enter their names in the empty field 
above the tree structure and click the  symbol on the right to start the search. Instead of searching for a 
full name, you can also enter the first letter, a number or a combination of letters and/or numbers.

Prefix a "/" to the search term when searching for a pro02id and an "#" when searching for a iid.
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3. Logs/Monitoring
A log shows all the activities involved in editing a signal here. Both the automatic measures and measures 
carried out by the user are taken into account. A wide diversity of logs and monitoring operations is 
summarised in GEMOS in the "Logs/Monitoring" module.

To access the logs go to: Master data > Logs/Monitoring

The following log data is summarised below the Logs/Monitoring button:

Interface status Shows interface status of client (see manual for installers)

Search for signal log Search for signal log

Search for detector status Search for specific detector statuses, e.g. all detectors that are switched off

Search call log Search for l log in which all activities in conjunction with the editing of 
outgoing/incoming calls are logged

Search change log Display and search for changes made in the master data

Server logs Display and processing of server logs

3.1 Interface status

To display the interface status, go to: Master data > Logs/Monitoring > Interface status

The web and Pro02 clients and their statuses, e.g. fault, ready for operation, etc., are listed.

Figure 3.1: Interface status

The information on the various interfaces is listed under the following column headers:

Login name, class, device name, device type, login status, device status

To set up a new Pro02 client, click on the new Pro02 client button. Click the  symbol to test the Pro02 
client.

3.2 Searching the signal log

To access the signal log go to: Master data > Logs/Monitoring > Search signal log.

If a search template does not yet exist, select the "Open search" and enter as the first step the information 
you are looking for in the form of search criteria, including search area (date or time stamp) and a time 
window (within a day).

To set up search templates, go to Basic configuration > Templates > Templates: Search. Setting up a 
template is more or less self-explanatory. The parameters are set in the same way as the open search. The
template is also given a name. By checking the box, this gives the user the option of modifying the search. 
Click Save to adopt the search template in the system.
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Figure 3.2: Search criteria - signal log

There are additional buttons in the bottom margin on the right (from left to right):

Start Starts the search using the specified search criteria

Reset Resets all search settings in the template

Print Prints the list of results

Export Exports the search results in csv, html, pdf or xls format

Open the downloaded file directly using the "Open" function. The import assistant ("Data" 
ribbon, "From text" function) is not working correctly. Several columns (signals, actions taken) 
may contain texts which are several lines in length. Excel only shows the first line of these 
texts as standard. Change the column format to "Text" to see the remaining lines.

The log data is then listed with the information on, for example, "Ser. No.", signal receipt, signal(s), cause 
of signal and measures carried out.
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Figure 3.3: Search result - signal log

3.3 Searching for detector status

Click the following buttons to search for a specific detector status: Master data > Logs/Monitoring > Search 
for detector status (select the template via the Search template field).

Figure 3.4: Search criteria for detector status search

Once the template has been selected, the search is performed and corresponding detectors are listed.

If a template does not yet exist, proceed as described under 55 Searching the signal log.
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3.4 Searching for call logs

To search for call logs, go to: Master data > Logs/Monitoring > Search for call logs

Figure 3.5: Search criteria for call logs

Once the template has been selected, the search is performed and the calls received are listed.

If a template does not yet exist, proceed as described under 55 Searching the signal log.

3.5 Change log

To access the change log go to: Master data > Logs/Monitoring > Change log

Time range Enter the time window for the search here

Pro02Id Enter the system Pro02Id you are searching for

Entries per page Enter here the number of entries that should be displayed on a page

The information in the change log is arranged in the following columns: version, time of change, user, 
workstation, data set, type of change, old value and new value.
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Figure 3.6: Change log

3.6 Server logs

To access the server logs go to: Master data > Logs/Monitoring > Server logs

Logs that are already active are displayed under "Active logs:". Additional logs with corresponding 
parameters can be set under "Start new log:".

Start new log: Select the log here, e.g. database, message, system or session log

Regexp Filter: Filter selection, "*" is the default setting, i.e. everything is written in the log

Priority Filter: Priority setting, e.g. (I) Info, (D) Debug, ...

File: File name under which the log is saved

Limit: Information on file size

Interval: Time interval is set here

Press Start Log to start.

View statistics: Enter the parameters by selecting them from the dropdown menu, press View to
display the information

Commands Press the Execute button to execute the commands
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Figure 3.7: Server logs
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4. Tools
Documentation for the system and deletion of an alarm stack can be found under the folder Tools. To 
access the tools folder, go to: Master data > Tools.

Files/Downloads List of documents relevant to existing modules, interface computers, etc.

Delete alarm stack The installer of the system can delete all signals in the alarm stack at once, or 
separately according to signal categories here.

Powertools Collection of tools/macros that make it considerably easier to work with GEMOS

4.1 Files/Downloads

Press the Files/Downloads button to list the following documents/downloads:

documents, files for installation on web clients, files for installation on interface computers, miscellaneous 
downloads.

Figure 4.1: List of system documents

Different files can be downloaded at this point WITHOUT having to access the server. All interface 
documents can be viewed here using the Adobe Acrobat Reader, the interface programs themselves 
downloaded for installation on separate interface computers and tools for installation on web clients may 
also be available.

4.2 Deleting the alarm stack

During the configuration phase it is possible for cards that are not yet fully configured and adjusted to 
produce a large number of signals. These must normally be removed manually from the alarm stack. The 
installer of the system can therefore delete all signals in the alarm stack at once separately following 
filtering by clicking on Master data in the menu bar then the Delete alarm stack button under Tools. The 
signals in the alarm stack can be deleted separately according to signal categories in the mask that 
appears next.
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Figure 4.2: Deleting the alarm stack

This function is reserved for administrators only. If other users are to perform actions of this kind, they must 
explicitly be assigned the rights to do this.

To do this, select the filter under Basic configuration > Signal processing > Stack filter then assign the 
deletion rights separately according to user groups under the Joint actions tab.

4.3 Powertools

Powertools can be accessed via Tools > Powertools and are a collection of macros or auxiliary programs 
that make working with GEMOS easier.

4.3.1 Test signals

Signals from all subsystems can be simulated here. To do so, select the detector for which a signal is to be 
simulated in the technical tree. The current status and signal statuses that the detector can deliver, among 
other things, are displayed on the right-hand section of the screen. Select the required status and click 
Execute (enter further parameters if required)
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Figure 4.3: Triggering the test signal using the Powertool

4.3.2 gmm-Viewer

The gmm-Viewer lists all installed modules and interfaces of the system. Modules and interfaces can be 
found in the "resources" directory in GEMOS and are packed in files with the extension *.gmm. These files 
can be unpacked and their content displayed on the screen using the gmm-Viewer (with pdf or cfg files). If 
you wish to edit a file, select it and click on Copy. The file is then saved in a subfolder under "resources" 
where it can be edited. The subfolder has the same name as the module and must not be renamed.

GEMOS uses the configurations in the subfolder under "resources" as a priority and only uses the 
configuration from the module itself if these folders do not exist or are empty.

4.3.3 Link Import

Link Import is a tool which can be used to import lists of detector pairs. To do this, comma-separated lists 
must be saved in *.txt format in the root directory of GEMOS where they are located and displayed for 
selection by the Link Import tool.

Example: special links are to be created from perimeter fence sensors to alarm cameras.

In this case it would be feasible to prepare a list in Excel the first column of which contains the fence sensor
and the second column of which contains the list of pro02ids of the cameras to which the special links are 
to be established. This list can then be saved in csv format, converted to txt format then copied to the 
GEMOS directory.
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The import itself involves 5 steps:

Step 1: Once the Powertool has been called up, this list is located and made available 
for selection. Click the required file then click Next.

Step 2: Select the separator for the data and and specify whether the first line should be
read. The internal separator separates the source and target in the data 
internally.

Step 3: Specify which data is in which field. The detector that is triggered is regarded as 
the source of the link (i.e. the fence detector in this case) and the detector to 
subsequently be found (the alarm camera in this case) is regarded as the target
of the link

Step 4: Select the link type (if not already specified in the txt file), i.e. the alarm camera 
in this case

Step 5: Perform import

If in doubt, initially carry out an import using a file containing one line and check the result before working 
with a complete txt file.

4.3.4 Sensor-Exchange

This Powertool makes it possible to exchange detectors in location plans, individual measures, measures 
plans, button scripts and time measures. The required data is exported from a file. The tool searches for 
files with the extension ".txt" in the root directory of GEMOS Pro02Server. The import progress is displayed 
in the "powerTools" log.

Follow the same procedure as that described in the section 4.3.3 Link Import but select "pro02id alt" and 
"pro02id-neu" instead of the source and target of the link.

4.3.5 Applying the detector status

The specified status is applied for ALL relevant detectors. Although precisely one desired status value can 
be specified per status group, several statuses can be transmitted at the same time, e.g.: 301,101 (ready 
for operation, clear).

The HexCode of the status must be stated without 0 or 0x. If the Pro02Id field is empty, all detectors will be 
set. The specified Pro02Id to which a "%" is appended is used as the filter condition for a SQL instruction. If
the field with the regular expression contains a value, this is applied to the detectors found and only 
corresponding detectors are set. The preview shows a list of all detectors that are set.

4.3.6 Deleting trees

This tool deletes entire trees from the hierarchy and removes the links beforehand
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5. Basic configuration
To access the basic configuration folder, go to: Master data > Basic configuration

The following configurations are displayed under Basic configuration:

User interface The user interface is configured here
(colours, start framesets to be loaded,...)

Framesets Configuration of different system framesets

Signal processing Settings for various signal processing operations

Addresses/Contacts Configuration of different addresses and contacts

Telephony control Configuration of telephony control

Links/Data fields Configuration of data fields and links

Templates Configurations of templates from the theme editor, from search templates and 
the visualisation
(for further information refer to the manual for installers!)

Modules Configuration of various modules
(for further information refer to the manual for installers!)

Interfaces Configuration of various interfaces
(for further information refer to the manual for installers!)

Tools Useful tools for the installer
(for further information refer to the manual for installers!)

5.1 User Interface

To configure the master data go to: Master data > Basic configuration > User interface. Then select User 
interface from the folder tree on the left and finally: Basic setting.

5.1.1 Basic setting

In the basic setting, general system settings are performed as well as visualisation of the user interface and
various configurations of the control panel.

5.1.1.1 Settings

General settings:

Design (theme) The appearance of GEMOS can be determined via this menu. The themes are 
designed in the Theme Editor (Master data > Basic configuration > Templates)

Touchscreen If you are using a touchscreen this must be specified here

Log commands Check this box to log commands.

User login:

Automatic login An automatic login can be generated after a desired time (in seconds) using a 
desired user name. The chosen user must not be protected by a password.

Following login: Selection of a defined interface that is to be displayed following login 
(visualisation, master data, …)
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Following logout: Window to be displayed following logout (for logging back in, ...)

Master data:

Reason for change When this box is clicked, a text input field in which changes to the master data 
can be logged is displayed. This information can be entered optionally or can 
even be made compulsory.

Create new persons in: Specify where new persons should be created here (local or access control)

Figure 5.1: User interface: basic settings (settings)

5.1.1.2 Visualisation

Layout display:

Start-Frameset The required frameset must be selected from a drop down list box.

Detector name States how detector names are to be displayed on location plans (pro02id, 
designation, path, ...)

Detector tool tips see detector names

Highlighting of detector
in the event of an
alarm

The triggering detectors can be circled and/or can flash when the alarm is being 
processed in order to draw attention to them. The triggering detector can appear
together with other detectors or separately.

Text for legend A legend for the location plan in which a wide range of parameters (e.g. creation
and last change made in location plan, processor and version number) can be 
displayed optionally or generated automatically. A user-defined text can be used 
for the legend, placeholders are available

Actions when clicking on layout elements:

Cameras/Monitors: You can specify here whether a panel should be opened when clicking on a 
camera or a monitor or whether the monitor should be selected as an active 
monitor and the camera connected

Alarm stack:

Standard filter: Menu for adjusting the standard filter for the alarm view (standard setting: all 
signals)

Release time: Time in seconds until the standard filter settings are restored

Signal processing:

Initial position Position of signal panel (X, Y input)
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Form of handling 
instructions

What form should the handling instructions take (flow text, list,...)

Reminder intervals The reminder intervals for signals or alarms not yet processed can be entered 
here (comma-separated list, e.g.: 30m,1h,24h)

Figure 5.2: User interface: basic settings (visualisation)

5.1.1.3 Control panels

Detector control panels, general:

Initial position Position of detector control panel (X, Y input)

Format title/detector 
name/sub-detector

Format of title/detector name/sub-detector

Displayed data fields Display list of data fields

Displayed links Display list of links

Telephony panel:

Call list, width 
line/overall height

Configuration of call list

Speed dialling, button 
width/column height

Configuration of speed dialling
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Figure 5.3: User interface Configure control panels

5.1.2 Users with special settings / other users

The configuration of the user with special settings / other users (settings, visualisation and control panels) 
is along the same lines as the basic settings. If a user with special settings logs in, these settings take 
precedence when loaded. They "overwrite" both the standard settings and the settings at the workstation at
which the user logs in.

5.1.3 Workstations with special settings / other workstations

The configuration of workstations with special settings / other workstations (settings, visualisation and 
control panels) is along the same lines as the basic settings. If a user with special settings logs in at a 
workstation, these settings take preference when loaded and the standard settings are "overwritten".

5.1.4 Colour templates

12 predefined colours are available in GEMOS for a range of alarms and/or status displays of the 
detectors. If more colours are required in order to identify individual events or statuses, these can be 
configured here.

Figure 5.4: Predefined colours
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Add colours Click on the symbol  to display the input screen in which a new colour can be 
created: a name must be assigned to the new colour and a colour value entered
in the colour code field as a hexadecimal number (rrggbb, Hex). A preview 
image is displayed. This must be saved.

Delete colours Press the following button to delete a colour:  

The 12 predefined colours in GEMOS cannot be deleted!

5.1.5 Text boxes

There are 4 predefined font styles. Additional font styles can be defined.

Add text boxes Click on the + symbol to generate a new font style / text box which must 
subsequently be named.

Remove text box Press the following button to delete a text box: 

When installing new fonts on the server, the browser cache must be emptied once and the 
page reloaded before these fonts can be displayed in the preview and the layout!
The 4 predefined text boxes of GEMOS cannot be deleted!

Figure 5.5: Adding new text boxes
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5.2 Framesets

The user interface consists of individual location plans loaded in a frameset. At least one frameset which is 
to be used for the default settings of the user interface must exist.

Additional framesets are possible, e.g. for supplied workstations (touchscreen for barrier control, …) or also
service workstations (laptop of service technicians, ...)

A number of framesets are already preconfigured (1 or 2 screen system(s)).

To set up a new frameset, proceed as follows: Master data > Basic configuration > Framesets. Make 
selection from System data/Framesets tree on the left and click on   under "Add":

Figure 5.6: Display of a frameset in the master data

Designation: Enter the name for the frameset, this can be any name

Sorting sequence empty=alphabetical, 999=assignment in no particular order 

The subdivision of the screen required by the operator for signal processing is carried out when configuring
the framesets using any given number and size of frames. The location plan which is loaded and the 
corresponding frame in which it is loaded is defined when creating the location plan.

The individual frames are assigned different functions.

For logical reasons, a GEMOS interface comprises an alarm stack, navigation options, different 
layouts/location plans with floor plans or buttons and options for changing to the master data or other 
functions.
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5.2.1.1 Creating a frameset

Although a frameset is created and edited in exactly the same manner as a location plan, it mainly consists 
of frames which subsequently display the content at the user interface. The incorporation of graphics from 
the import folder is possible, as is the use of dynamic navigation bars, hierarchy tree, menu bar or similar 
elements.

Example for the creation of "Frame1": select "Insert" tab and click the Frame button in this tab. A new frame
appears in the editor and must be configured. In this case, it is sufficient to give the frame a name, position 
and size and to define the initial content (here: layout/location plan).

Figure 5.7: Example of a frameset (alarm stack at top 1024x768)

Position+Size x, y coordinates of the top left-hand corner of the frame and width and height in 
pixels

Frame:

Name Enter the name of the frame here

Initial content Select what the frame should contain when opened

Decoration Select whether frames or scrollbars should be used

Use later for Select corresponding content here, e.g. by checking detector control panel or 
alarm processing box
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Figure 5.8: Set up of a frameset

5.3 Signal processing

To call up the "Signal processing" menu, go to Master data > Basic configuration > Signal processing.

The configuration of the signal processing is organised according to the following data groups:

• Signal categories

• Signal locations

• Signal causes

• Signal priorities

• Stack filters

• Stack formats

Although in principle, all workstations are handled equally in GEMOS when processing signals, in systems 
with several workstations it is also possible to organise the distribution of different signal types. This means,
for example, that fault signals can be displayed at one workstation, and alarm and other signals can be 
displayed at other workstations. This allows the allocation of workstations to be more closely linked to 
function.

5.3.1 Signal categories

Each category can be assigned a name in the signal category screen in the master data configuration. 
Bear in mind in doing so that only the area from numeric code 100 onwards is available for user-defined 
categories. The numbers 0-99 have already been assigned a meaning.

Priorities, signal tones and colours are assigned via signal categories. A signal is assigned to a category via
measures plans. This may change dynamically depending on the secondary conditions.

The categories are subsequently combined in filters the responsibility for which can be distributed among 
the workstations.
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Figure 5.9: Signal categories

The display of a signal category in the alarm stack and the corresponding acoustic signal is configured 
here.

Signal categories are set up according to the following parameters:

Designation(s):

German Designation of individual category

Settings:

Numeric code Numeric code of the individual category

Priority Signal priorities

Colour of new signals Colour of alarm/signal – new

Colour of processed 
signal

Colour of alarm/signal – processed

Holding time Holding time of signals in this category in seconds

Subsequently reverts to Category to which signal is moved following the holding time

Alarm sound Selection of a sound and the interval (sec.)

To set up signal categories, proceed as follows:

• Create a new signal category with 

• Enter the designations in the required languages

• Enter a category of your choice from numeric code 100 onwards

• Select the necessary signal priority from the pull-down menu

• Define the test and background colours in order to be able to visually differentiate between 
alarms

• Define time (in sec) that elapses until a reminder is issued in the event an alarm is not 
processed

• Select the category of the alarm in the event it is not processed once the time period defined 
above has elapsed

• Select an alarm sound via an additional pull-down menu

• Save 
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5.3.2 Signal locations

The signal locations allow basic differentiation of signals according to location (building) which makes it 
easier to evaluate the log and filter signals in the alarm stack. A signal is assigned to a location in the 
corresponding measures plan.

5.3.3 Signal causes

The most important aspect for completion is the cause of the signal. This means that the logs saved can be
systematically evaluated based on specific events. The message cause must be selected as completion 
will otherwise not be possible.

Figure 5.10: Signal causes

When configuring the causes of signals, the preset parameters are sufficient. Additional signal causes can 
however be defined via  .

5.3.4 Signal priorities

If several signals arrive from different detectors at the same time, the signals are displayed in the alarm 
stack in the order of priority. In this case, the lowest priority is -20 (no priority over other signals), and the 
highest is 20 (priority over all other signals). A signal is assigned to a priority based on the signal category, 
or in the corresponding measures plan directly.

Figure 5.11: Signal priorities

A numeric code and designation is then assigned to the signal priorities and subsequently saved. Code 0 
denotes a neutral priority, positive values denote a higher priority and negative values denote a lower 
priority. Press  to add a new priority.
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5.3.5 Stack filters

Figure 5.12: Alarm stack filter

Possible entries:

Designations Enter the required designations in various languages

Numeric code Enter the code for self-defined filters within the range of 10-500

Display format see stack formats

Max. number of signals Specify the maximum number of signals in the stack

Filter criteria Select the category filter here
Click the box to define the type of filter

Several categories can be loaded in one filter here, e.g. the "Faults" filter can contain system faults and 
central faults.

The filters are then assigned via the access rights of different workstations and/or user groups.
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5.3.6 Stack formats

The column arrangement and sorting of entries in the alarm stack are defined by alarm stack formats. The 
designation, display limit, sorting criteria and column layout are configured here.

Figure 5.13: Alarm stack formats

5.4 Addresses/Contacts

To perform the basic configuration of addresses/contacts go to: Master data > Basic configuration > 
Addresses/Contacts. The following address or contact data can be selected: form of address, title, contact 
types, languages and countries.

Figure 5.14: Contact type, mobile phone

Further address or contact data can be entered via the  symbol.

5.5 Telephony control

To configure the telephony control, go to: Master data > Basic configuration > Telephony control The 
following four groups exist: contact types (call number plans), locations, call types, call history and call 
alarms.
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5.5.1 Telephony control - contact types

Figure 5.15: Telephony control - contact types

The various data can be entered or tested under General, Advanced and Call number substitution. The 
designation (e.g. telephone) and the settings (contact type, a corresponding icon, the type of display, a test 
sample, the device and speed dialling numbers) can be entered under General. An additional call number 
substitution can be found under Advanced.

5.5.2 Telephony control - locations

Figure 5.16: Telephony control - locations

Location-dependent configuration options for telephony. Please bear in mind that the call 
stations must be assigned to a location!

The different data can be entered or tested under General, Advanced and Call number substitution here. 
The designation (e.g. location), call number plan (number for outside line, national code, area code and 
private call number plan) and the speed dial (speed dialling numbers, contact types) can be entered under 
General. An additional call number substitution (inbound and outbound) can be found under Advanced.
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5.5.3 Telephony control - call types

Figure 5.17: Telephony control - call types

Call types classify different types of telephone calls (e.g. emergency call as opposed to 
normal telephone call). They can be sent from the telephone system or assigned 
retrospectively by the user.

You can also enter diverse data here under General and Communication objectives. The designation (e.g. 
location), the settings (a symbol, the foreground and background colour, a priority, different ringing tones 
and their interval), a call type classification (various conditions in relation to previous call type, calling 
number, queue and call attributes) and action to be taken in the event of an alarm (display alarm signal) 
can be entered under General. The designation and call number can be found under Communication 
objectives.
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5.5.4 Telephony control - call history

Figure 5.18: Telephony control - call history

A range of data can also be entered here under General and Advanced options. The designation (e.g. open
search), the time range (search area, time window), the telephony system (facility components included, 
facility components excluded, detector class, Pro02-ID, workstation) and the call attributes (queues, call 
types, call direction, call status and call number) can be entered under General. Additional enquiry options 
(max. data sets per screen page, max. data sets per export) are available under Advanced options.

5.5.5 Telephony control - call alarms

Call alarms constitute the interface between the telephony control and the alarm stack or signal log. They 
are triggered based on the call type (see relevant section) and can be called up as an event in the 
measures plan. The designations configured here are displayed in the stack and in the log. 

5.6 Links/Data fields

Project-specific data fields and various link types can be configured via the Links/Data fields button.

5.6.1 Project-specific data fields

The project-specific data fields can be found under Master data > Basic configuration > Links/ Data fields.

To create project-specific data fields, the new data field must be given a designation (in several languages 
if necessary) and then saved.

Settings:

Numeric code Code between 1000 and 9999

Valid for Specify validity, presetting is selected as standard
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Type Define the data field type

Example (is only displayed/updated after saving)

Press  to save the data fields.

Figure 5.19: Special data fields

5.6.2 Link types

Self-defined reference types, such as alarm camera, alarm monitor, control monitor, operating device or call
station can be generated by giving a new reference type a name, entering the corresponding links "Source 
– Target" and then saving. Example:
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Figure 5.20: Special reference types

Figure 5.21: Link types, example with alarm camera

The catalogue sample has the following general structure:

[«result»] «condition» [;[«result»] «condition»[;...]]
In this case [ ] denotes optional parts, ... denotes a repetition, «» denotes elements that must be replaced 
by a specific value (see below).

The partial printouts (separated by ; ) of the catalogue sample are processed from left to right until one with
the corresponding condition(s) is found. The corresponding result for the condition is then used. Other 
partial printouts are ignored.

Results

selectable The object is visible and selectable (preset, if no other result is stated).

visible The object is visible, but not selectable.

81 10/2014 | revision: 1.2 | Printed in Germany



GEMOS4 operator manual Basic configuration

traversable The object is invisible but can be traversed when making the selection in the tree.

hidden The object is always invisible.

Frequently used conditions:

type:«regex» Checks for a specific object type. Examples of possible types are 1=detector, 
2=device, 3=folder, 12=area

id:«regex» Checks conformity of pro02id.

class:«regex» Checks for a specific detector class (e.g.: "class:[IF]" for fire or burglar alarms).

tech Checks for an arbitrary technical element (device, detector)

Several conditions (separated by blanks) can also be specified. These are then ANDed. The reference 
value of a condition is (unless specified otherwise) a so-called "regular expression".

5.7 Templates

The following data groups are realised via the Templates button during the basic configuration of the 
GEMOS4: the theme editor, different search templates and the visualisation.

The Templates button can be accessed via: Master data > Basic configuration > Templates.

The templates are normally generated by the system installer when setting up a system. To 
gain an in-depth understanding of setting up templates, this procedure to be followed by the 
system installer is therefore explained in detail in the manual for installers.

5.7.1 Theme Editor

The Theme Editor button can be accessed via: Master data > Basic configuration > Templates > Theme 
Editor.

Figure 5.22: Theme Editor
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5.7.2 Search templates

The search templates button can be accessed via: Master data > Basic configuration > Templates > Search
templates

The search templates belong to one of the following three groups: search templates for detector names, 
search templates for logs and search templates for call history.

Also see chapter 3 for details.

Figure 5.23: Search templates - detector

Figure 5.24: Search template - logs
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Figure 5.25: Search template - call history

5.7.3 Visualisation

To access the Visualisation button go to: Master data > Basic configuration > Templates >Visualisation

For details see 5.1.1.2 Visualisation

Figure 5.26: Visualisation

5.8 Modules

The following data groups are realised via the Modules button during the basic configuration of GEMOS4: 
install modules, Pro02 server configuration and master data print configuration.

The Modules button can be accessed via: Master data > Basic configuration > Modules.

The modules required for the system are normally installed by the system installer when the 
system is set up. To provide the system installer with a greater understanding of the various 
modules, the detailed procedure is therefore explained in the manual for installers.

84 10/2014 | revision: 1.2 | Printed in Germany



GEMOS4 operator manual Basic configuration

5.9 Tools

Additional tools are available at: Master data > Basic configuration > Tools. These are used to deleted the 
change history and provide a range of special functions, such as localisation, various User Interface Tests, 
an overview of the master data classes and an overview of the code classes.

The tools are normally used by the system installer when installing a system. To give the 
system installer a greater understanding of the tools, the procedure is explained in-depth in 
the manual for installers.

5.9.1 Deleting the change history

To delete the change logs (history) go to: Master data > Basic configuration > Tools > Delete change history
GEMOS makes comprehensive change control possible as virtually all changes to the system are logged. 
The date, type of change (from...to...) and also the processor are saved and a version number assigned.

Figure 5.27: Deleting the change history

Once the change logs have been deleted, the current status of the master data can be started using a new 
freely selectable version number which is entered via the selection box next to the text "Set version number
to". The most recent change can be given a date stamp and user name.

To access the Special functions button go to: Master data > Basic configuration > Tools > Special functions.
The localisation, User Interface Tests, overview of master data classes and overview of code classes are 
brought together under the umbrella of special functions.

5.9.2 Localisation

To access the Localisation button go to: Master data > Basic configuration > Tools > Localisation.
"Localisation" refers to the change of language or language version of modules. This affects, among other 
things, the display of detector statuses (0x101 could then be "neutral" instead of "clear", for example)

Figure 5.28: Localisation
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6. Help
To access the online help go to Master data > Help. The Help menu consists of 3 areas:

Online help Is a GEMOS online help which is tended by ela-soft and provides fundamental 
knowledge/support for GEMOS.

About GEMOS List of current system data

Project documentation This is an online help which can be updated by the user, operator or installer 
independently within the scope of the project, see section WIKI.

6.1 Online help

To add your own (project-specific) help texts in the GEMOS online help, use the symbol   "Edit" then save 
in the project documentation. The texts are displayed above the "official" help pages (program 
documentation). This function is only available to specially authorised users.

Figure 6.1: GEMOS online help

The following icons are used (see top right-hand side of frame):

 Edit (entry is made in the project documentation)

 Print

 Go to home

 Back

Delete
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6.2 About GEMOS...

To access the version info go to: Master data > Help > About GEMOS...

Figure 6.2: Overview of versions (excerpt)

The version information list can be printed  .

This list incorporates information on the GEMOS configuration, the various GEMOS modules (core 
modules, standard modules, function modules, interfaces, symbols and active modules), the components 
by other manufacturers and the general license data.
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6.3 Project documentation

Project documentation can be prepared via: Help > Project documentation.

Figure 6.3: Project documentation

You can add your own (project-specific) help texts in the GEMOS online help via the "Edit" symbol then 
saved in the project documentation. The texts are displayed above the "official" help pages (program 
documentation). This function is only available to specially authorised users. Use the "WIKI" document 
script to prepare project-specific help texts.

6.3.1 WIKI format

Articles are entered in a subset of the "MediaWiki" format.

6.3.1.1 Article names

Articles that are referenced to functions of a specific module, are named in the form "«gmmname».«topic»".

The following characters must not be used in article names under any circumstances whatsoever: | (pipe 
symbol), # (hash symbol), : (colon).

6.3.2 Format elements

6.3.2.1 Headlines, paragraphs, dividers

  =Text= Headline level1

==Text==
  ===Text===

Headlines level2, level3, etc.

      ---- Four minus signs in a row produce a horizontal divider

Paragraph1
Paragraph2

An empty line produces a paragraph

<br> Produces a line feed

6.3.2.2 Font formatting

''text'' Italics

''text'' Bold

<pre>....</pre> Preformatted text (switches the handling of special characters off)
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6.3.2.3 Hyperlinks

[[«article name»]] Basic form of a cross-reference within WIKI

[[«article name»|«reference 
text»]]

Refers to the article "article name", but displays "reference text".

[[«article name»#«headline»]] Refers to a specific headline within an article

[«url»  «reference text»] External reference

[/!«module»/«file name»  
«reference text»]

Reference to a file from a module (e.g. a PDF file)

6.3.2.4 Incorporation of images

[[Image:#«iid»]] Display of an image from an import folder.

[[Image:«file name»]]

Display of an image. The image is expected to be found in the 
"«installation path»/data/images" folder. If the WIKI document is the online 
help of a GEMOS module, it is assumed that the image will be in the 
resources of the module.

[[Image:/!«module»/«file 
name»]]

Display of an image from the resources of a specific module.

[[*ThemeIcon:«name»]] Display of an icon from the selected theme.

6.3.2.5 Lists

* Point1
* Point2
* Point3

Simple list:

Point1

Point2

Point3

# Point1
# Point2
# Point3

Numbered list:

Point1

Point2

Point3

* Point1
** Point1a
** Point1b
* Point2
*# Point2a
*# Point2b

Hierarchical list:

Point1

Point1as

Point1b

Point2

Point2a

Point2b

; Word1
: Explanation1
; Word2
: Explanation2

List of definitions:

Word1

Explanation1

Word2

Explanation2

Note: a list must always end with a blank line to indicate the end of the list.
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6.3.2.6 Tables

{| Identifies the start of a table

| «text» Text of a column

| «text» || «text» || «text» Several columns in a line

|- Identifies the start of a new line

|} Identifies the end of a table
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7. Glossary
A

Action log Action logs save user actions.

Alarm sound The alarm sound provides further options for differentiating between 
the alarms in the alarm stack.

Alarm stack The alarm stack is the list of newly arrived messages or messages 
that have not been processed yet.

Area Areas represent the compilation of several detectors within the 
GEMOS systems. They can be compared with message lines in the 
alarm technology.

Assault detector See intrusion detector

B

Building management Building management considers the technical, commercial and 
infrastructural services during the utilisation phase of a building as a 
whole and is therefore a part of the facility management.

Button Buttons may be arranged within the floor plans for activating certain 
actions. The buttons are freely programmable.

C

CAD Computer-aided design

CGI Common Gateway Interface – a CGI makes it possible for a WWW 
browser to execute programs via a WWW server.

Clients Service-requesting device (GEMOS interface software)

CSV Comma Separated Values (a file format)

D

Decision-making tree Measures plans can be generated with the assistance of macros.

E

Expert mode In expert mode, GEMOS can generate an extremely wide range of 
individual measures/measures plans using a script.

F

Facility Management Facility Management is the observation, analysis and optimisation of 
all cost-relevant processes relevant to the building that do not belong 
to the core business of a company. This involves the analysis of a 
building throughout its service life, starting with the design, planning 
and construction followed by use through to reuse or demolition. All 
relevant data is saved within a common database.

Fire detector Being a "Watchdog on-location", fire detectors are responsible for the
detection and reporting of a fire at the earliest stage of development. 
Ionisation smoke detectors, optical smoke detectors, flame detectors,
heat detectors and transmitted light smoke detectors are applied 
most frequently.
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Floor plans Floor plans constitute the central component of the GEMOS user 
interface. They schematically represent the monitored building and 
the building's signalling technology in the operating software, thus 
providing the user a quick overview of the entire system in everyday 
operation, and a detailed representation of the locations affected in 
the event of an alarm.

Frame Area on screen

G

Gateway Gateway refers to a connection or transition point between two 
fundamentally different networks using different protocols, different 
addresses, etc. A gateway is normally a computer that acts as the 
intermediary between different network worlds.

GEMOS – System bus The GEMOS system consists of the PC workstation itself with the 
GEMOS operating software, the interface modules (interfaces) and 
the GEMOS system bus. Any security, building services and 
communications systems can communicate via the GEMOS system 
bus, and their signals can be visualised and processed at the PC 
workstation. The bus makes it possible to distribute the system 
intelligence over large distances.

gif The Graphics Interchange Format was introduced many years ago by
the online provider CompuServe. It is characterised by high 
compression. It therefore quickly became established in the online 
sector where it costs time and money to transmit data. Nowadays the
"89 format" is the widely-used standard gif format. One disadvantage 
of the gif format is that it can only save a maximum of 256 colours 
per file.

GLT Abbreviation which stands for "Gebäudeleittechnik" (building 
management technology)

H

HDD High Density Device - hard drive recorder

I/J

Intrusion detector Intrusion detectors belong to the group of danger alarms, such as 
assault and fire detectors. Their purpose is to provide a reliable signal
in the event of danger to persons and property. They generate 
danger signals based on information that is captured automatically or
caused by persons, communicate this information and record faults.

jpeg stands for Joint Photographic Expert Group, i.e. this not the name of 
the graphic format but the name of the corporation that developed the
format. The jpeg method is a compression algorithm for data flows 
which is based on the DCT (Discrete Cosine Transformation) 
algorithm in conjunction with Huffman coding. With the file format of 
the same name for graphics, this algorithm has simply been applied 
to pixel graphics. In the meantime the jpeg algorithm has also been 
applied to videos which has brought about the popular MPEG video 
format.
As with gif format, the jpeg graphic format compresses extremely 
effectively and has the advantage compared to gif of being able to 
save up to 16.7 million colours per image. It therefore works with the 
entire colour spectrum and not just colour palettes containing specific
colours as is the case with the GIF format. The disadvantage of jpeg 
is a loss of quality during compression. The higher the compression 
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factor, the greater the quality loss.
Losses occur when compressing jpeg graphics, particularly if abrupt 
colour transitions occur in the picture, i.e. if the objects shown have 
corners and edges ("jagged edges"). The jpeg format is therefore not 
suitable for images containing a few colours but clear contours, i.e. 
for simple drawings, contrasting lettering, etc. However, the format 
comes into its own when saving photos and other graphics containing
extremely fine colour graduations. Even when slightly compressed, 
the file sizes are already significantly smaller than bitmap graphics. 
Even photos that fill the screen can be saved in jpeg format to a 
useful quality with file sizes that could be regarded in the web as 
being acceptable.

L

Location plan editor The location plan graphic is designed in the location plan editor. 
Functional elements in a graphic are detector symbols, windows, 
buttons, texts and graphics.

M

Measures plan The measures assigned to a signal are incorporated into measures 
plans. They control the behaviour of GEMOS when a signal arrives.

Messages Messages are status changes reported from the signalling devices 
connected to GEMOS. Besides alarm messages, these could also be
malfunction and regular status messages.

Message categories Message categories sort the alarm stack and also regulate the 
distribution of messages to the individual workstations.

MLK Abbreviation which stands for "Meldelinienkarte" in German (literally 
translated means "detection line card") – hardware component in 
GEMOS

P

Perl Practical Extraction and Report Language - programming language 
for CGI scripts

Pixel pixel element - pixel

PHP Professional Home Page – Hypertext Preprocessor – PHP is a 
server-side script language which is embedded in HTML and is 
therefore an Internet server extension that allows dynamic websites 
for multimedia or e-commerce applications to be created in the 
Internet with relatively little effort.

Polling operation  cyclical scanning of devices or detectors by control centre

Pro02 The Pro02 server processes all signals from connected clients and 
manages correct communication between the participants in the 
system on the basis of the TCP/IP protocol.

Pseudo detector A pseudo detector is a detector that has no reference to an external 
facility. It is only managed internally by GEMOS.

R

RGB "Red / Green / Blue" - Colour scheme

RLK Abbreviation which in German stands for "Relaiskarte" (literally 
translated means "relay card") - integral hardware component in 
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GEMOS

S

Signal cause The cause of a triggered signal is issued once processing of the 
signal has been confirmed as complete so that the saved logs can 
subsequently be systematically evaluated following specific events.

Signal log Signals are listed or printed out in the signal logs. Limiting of the 
selection criteria is possible.

Signal priority Signals are displayed in the alarm stack in order of importance.

Signal processing core  The central signal processing core processes all signals from 
connected clients and manages correct communication between 
participants in the system based on the TCP/IP protocol.

Single action Single actions are the actions that must be initiated following an 
incoming message in the GEMOS system. They are combined to 
action plans later and then assigned to an event.

SQL Structured Query Language - data retrieval language

T

TCP/IP Transmission Control Protocol/ Internet Protocol is an Internet file 
transfer protocol. It nests files in packages. These are numbered 
consecutively and reassembled at their destination. As errors can 
occur during data transmission, a checksum is sent with the package 
and checked once again at the destination. Packages with incorrect 
checksums are requested again.

Tree structure See hierarchy window

U

URL "Uniform Resource Locator" - Branch address in the internet

User interface The user interface is the central system component of GEMOS. It is 
required for the processing of incoming signals.

V

Video crossbar Each camera can be switched to each monitor using a video 
crossbar.

W

WAN Wide Area Network - refers to a network which extends over a large 
area, sometimes internationally, and often consists of a connection 
with local networks which are far away with the help of telephone 
lines.

X/Y/Z

ZIF Abbreviation which in German stands for "Zentraleninterface" (literally
translated means "central interface") - integral hardware component 
in GEMOS
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8. Revision

Revision Date Editor Explanation

0.5 30.08.12 MJ Creation

0.6 04.10.12 JP, MJ Correction, supplement

0.7 30.10.12 JP Correction, supplement

0.8 08.11.12 JP, MS Correction

1.1 08.04.13 RK Correction, supplements

1.2 08.10.14 CR Correction, Layout
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