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1. Document versions

Version | Date Author Description
1.0 11/2023 IDP First version
1.1 12/2003 JCR Review
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2. Introduction

This document explains how to install and use the Paradox Monitor software solution.

It also outlines the installation processes for the different applications that are required for the
Paradox Monitor to work correctly.

The Paradox Monitor software solution consists of a web service and a plugin that
controls the Paradox panels, namely:

the SGSE Panel Integration Service, which manages the connections with the panels,
and

the Paradox Monitor Plugin, which facilitates the integration of the Paradox panels
into XProtect.
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3. Architecture

The diagram below shows the architecture of this software solution.

Garadox Monitor Plugin

XProtect Management

SGSE Panel Client
. XProtect Event o
Integration
] Server :
Service XProtect Smart Client

XProtect Smart Client

Paradox Panel _

The web service manages the connections with the panels and displays an application
programming interface (API) through which it communicates with the plugin that is located
within the XProtect event server. The web service therefore integrates the devices connected
to the panels and their alarms through XProtect messaging.
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4. Installation

Install the plugin on the machine the XProtect Event Server is running. To install the
service, just run "SGSE Panel Integration Service Installer.msi" with administrator permissions.
This installer is supplied by SGSE and the installation process is automatic. The installer will take
you through a series of dialog boxes through which you will be asked to accept the End User
Licence Agreement. The plugin cannot be used if the End User Licence Agreement is not
accepted.

The following images show all the dialog boxes that will appear during the installation
process for the applications mentioned previously.

ﬁ SGSE Panel Integration Service — 4

Este es el Asistente para instalacién de SGSE
Panel Integration Service L [ m

Elinztalador le guiara a través de los pasos necesarios para instalar SGSE Panel Integration Service
en el equipa.

Advertencia: este programa esta protegido por lag leves de derechos de autar y otros tratados
internacionales. La reproduccion o distribucion ilicitas de este programa, o de cualguier parte del
mizmo, esta penada por la ley con severas sanciones civiles v penales, v seré objeto de todas las
acciones judiciales que carezpondan.

4 filras Siguiente » Cancelar

Click "Next >" to start the installation.
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ﬁ SGSE Panel Integration Service — x

Contrato de licencia TR m

[Dedigue unos ingtantes a leer el Contrato de licencia incluido en el programa. Si acepta laz
condiciones, haga clic en "Acepto y luego en "Siguiente'. De lo contrano, haga clic en "Cancelar'”.

End-User License Agreement (EULA) of "Panel Integration” Service ~

This End-User License Agreement ("ELULA") i= a legal agreement between you
{the "User") and Soluciones Globales de Seguridad Electranica (SGSE).

This EULA agreement governs your acquisition and use of our "Panel Integration
Sernvice" ("Software”) directly from Soluciones Giobales de Seguridad Electronica
[SGSE) or indirectly through a Soluciones Glohales de Seguridad Electronica

W

(i Mo acepto (®) Acepto

< filras Cancelar

You will need to read and accept the End-User Licence Agreement in order to proceed
with the installation.

ﬁ SGSE Panel Integration Service — x

Confirmar instalacion AT m

Elinztalador esta listo para instalar SGSE Fanel Intearation Service en el equipo.

Haga clic en "'Siguiente' para iniciar la inztalacion.

< Alraz Cancelar
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Click "Next >" to continue.

Control de cuentas de usuario b4

;Quieres permitir que esta aplicacion de un
anunciante desconocido haga cambios en el
dispositivo?

If a Windows User Account Control dialog box appears, you should consent to allowing
the installer to continue with the installation.

ﬁ SGSE Panel Integration Service — x

Instalacion completada U m

SGSE Panel Intearation Service se ha inztalado cormectamente,

Haga clic en "Cerar'’ para zalir.

4 fifraz Cerrar Cancelar

Once the installation has completed, click on "close". The service will now be installed
on your system.

To install the plugin, run "SGSE Paradox Monitor Plugin Installer.msi" in the same way
as "SGSE Panel Integration Service Installer.msi" was run to install the web service.
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ﬁ SG5E Paradox Monitor Plugin — x

.

Este es el Asistente para instalacion de SGSE
Paradox Monitor Plugin L m

Elinztalador le guiara a trawvés de los pasos necesanos para instalar SGSE Paradox Monitor Plugin
en el equipo.

Advertencia: este programa esta protegido por lag leves de derechoz de autar y otros tratados
internacionales. La reproduccian o distribucian ilicitas de este programa, o de cualquier parte del
mizmo, exta penada por la ley con severas sanciones civiles v penales, v zeré objeto de todas laz
acciones judiciales gque corezpondan.

< filras Siguiente » Cancelar

Click "Next >" to start the installation.

ﬁ SG5E Paradox Monitor Plugin — x

Contrato de licencia TR m

[Dedigue unos ingtantes a leer el Contrato de licencia incluido en el programa. Si acepta laz
condiciones, haga clic en "Acepto y luego en "Siguiente'. De lo contrano, haga clic en "Cancelar'”.

End-User License Agreement (EULA) of "Paradox Monitor” Plugin ~

This End-User License Agreement ("ELULA") i= a legal agreement between you
{the "User") and Soluciones Globales de Seguridad Electranica (SGSE).

This EULA agreement governs your acquisition and use of our "Faradox Monitor”
("Software") directly from Soluciones Globales de Seguridad Electronica (SG5E)
or indirectiy through a Soluciones Globales de Seguridad Electronica (3GSE) W

(i Mo acepto (®) Acepto

< filras Cancelar
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You will need to read and accept the End-User Licence Agreement in order to proceed
with the installation.

ﬁ SG5E Paradox Monitor Plugin — x

Confirmar instalacion U m

Elinztalador exta listo para ingtalar SGSE Paradox Monitor Plugin en el equipo.

Haga clic en "'Siguiente' para iniciar la instalacion.

< filras Cancelar

Click "Next >" to proceed with the installation of the software files.

Control de cuentas de usuario b4

;Quieres permitir que esta aplicacion de un
anunciante desconocido haga cambios en el
dispositivo?

If a Windows User Account Control dialog box appears, you should consent to allowing
the installer to continue with the installation.
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ﬁ SG5E Paradox Monitor Plugin — x

Instalacion completada U m

SGSE Paradox Monitor Plugin e ha instalado comectamente.

Haga clic en "Cerrar'’ para zalir.

tlice wWindows Update para comprobar cualquier actualizacion impartante de \MET Framework.

< filras LCerrar Cancelar

Once the installation has completed, click on "close". The plugin will now be installed on
your system.

Web service configuration
By default, the web service will be configured in the following way:

Web service TCP port

The default listening port will be port 12034. These settings can be changed by following
the steps outlined below:

"Kestrel™: {
"Endpoints™: {
"Http™: |
"Orl™: ™"http://*:12034"

ir

Accessing the admin user account

The default access credentials for the admin user account are as follows:
Username: admin

Password: Admin-123

10
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Both the listening port and the access credentials can be changed in the
“appsettings.json” file, which is located in the "C:\Program Files\SGSE\SGSE Panel Integration
Service" folder.

11
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5. Licencing

The plugin cannot be used without a licence that stipulates the number of panels and
devices that can be managed. These licences are generated by SGSE. The procedure for
obtaining a file for a licence that has been purchased is described below.

A. Obtaining UIDs
In order to generate the licence file, you will need to submit the relevant UID to SGSE.
This UID is a unique identification number with which the licence is associated.

To obtain the UID, install the plugin then run the XProtect® Management Client and go
to the plugin option in the side menu (MIP Plugins > Paradox Monitor).

The corresponding UID will be displayed on the screen if the plugin does not already
have a licence.

UID para licencia

Par favor, informe este UID a SGSE para que su licencia sea generada
| 1GEMG1B-8AKE8T-MZDWTS-1S02AGW

Copiar a portapapeles + Add License

You will need to submit the UID to SGSE. Once this has been done, a licence file for the
UID you have submitted will be generated.

B. Adding the licence to the system

SGSE will send you a file named "Licence.lic" and you will need to load this file on to the
system by clicking on the + Add Licence button. A dialog box will then appear allowing you to
select the licence file. The licence can also be added manually by copying the file to the
"C:\Program Files\SGSE\SGSE Panel Integration Service" folder.

12
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6. Configuration

The plugin has been designed to make the configuration process user-friendly so that
the installation of the Paradox Monitor goes as smoothly as possible. When the web service and
the XProtect Event Server are on the same machine, the plugin will be installed by default with
the configuration it needs to perform its functions. If the web service and the XProtect Event
Server are not on the same machine, the plugin will need to be configured separately.

Plugin configuration

Go to Tools > Options > Panel Management Server in the XProtect Management Client.
You will need to specify the URL address for the web service and the username and password
used to access it.

Opciones *
Eventos analiticos  Panel de usuaric  Alarmas y eventos  Eventos genéricos  Servidor de gestidn de paneles < >

Servidor de gestidn de paneles

URL del servidor de gestion de paneles

Ihttp://localhost 12034

Usuario

|ac|min |

Contrasefia

|......... |

Ayuda Aceptar Cancelar

If the configuration is incorrect, the following messages will be displayed:

Ha ocumido un ermor con la conexidn al servidor de gestion de paneles. Revise la configuracion del servicio de gestion de paneles.

o 8:52:20 Ha ocurrido un ermor con la conexidn al servidor de gestion de paneles. Revise la configuracion del servicio de gestién de paneles.

13
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/. Operation

XProtect Management Client
Go to MIP Plugins > Paradox Monitor > Paradox Panels. The panels that are registered
with the panel management service will be displayed here.

oo s e =& |[informacién de Fane Paradox i
E-= | Paneles Paradox
£ Nombre:  [panelt |
1P [152.163245 ‘
Pueto:  [10000 |
Usuaro: (1234 |
|

Contrasefia:  [swsnsns

Panelld: |1 |

Tipo de panel [AutoDetect ]

Tipe de COM P

ldioma: ENGLISH
Date Time: | || setdate
Habiltado

Panels can be added and removed by right-clicking on them.

Armpliar -
Borrar SUPR

| Afiadit nuevo...  CTRL+N |

Renombrar F2

E Actualizar F5

The following fields will need to be completed:

Field Description

E Actualizar Fa

Name Panel name

IP Panel IP address

Port TCP communications port for panel

User Panel user code

Password Password for connecting to the panel through the IP

Panel ID This is a unique number for each panel ranging from 1 to
65535.

Type of panel This relates to the type of panel you will be connecting to.

If it is an AutoDetect panel, this field will be completed
automatically when a connection is made to the panel for
the first time.

Once the information has been saved, the status of the connection to the panel and a
message to show whether it is ready for operation will be displayed at the bottom of the screen.

14
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Once the panel is connected, XProtect items associated with the area zones and outputs
for the panel will be created.

=%+ Plug-ins de MIP
(=182 Paradox Monitor
Et-a | Paneles Paradox

e "hf freas
- [ Zonas
Ly Salidas
Areas
Kreas ~ 1 [informacion de Area
Nombre: AreaZ

Nimero de area:

Etiqueta de area: Area 2a
Area habiltada
Habiltada:

15
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Zones
Zonas w 1 Qinformacion de Zona
= Zonas
E= | panell
| Zonel Nombre: Zone2
| Zone2
Mimero de zona: 2
Etiqueta de zona: Zane 002

Zona Habilitada:

Particion de zona: 1
Tipo: | ZXa2 ~
Habilitado:
Configuracion de alarmas
Disparar alamas
[] Asociar camara

The device type for each zone can be specified in the type field.

You can configure the creation of alarms for each zone and link them with cameras at

the bottom of the screen.

‘Configuracién de alarmas.
Disparar alarmas
Asociar camara

Grupos

=-f,] DESKTOP-FMEEDPS

Grupo de grupo de camaras 1
hikvision

i uniview

-0 UNIVIEW IPC2322EBRS-DPZ28-C (192.168.2.

- UNIVIEW IPC232455-DZK-10 (192.168.2.54) -

UNIVIEW IPC232455-DZKA0 (192.168.2 54} - Camara 1
UNIVIEW IPC2322EBR5-DPZ28-C (152.168.2.12) - Camara 1

Seleccionado:

B UNIVIEW IPC232455-DZK-I0 (192.168.2.54) - Camara 1

Afiadir

= UNIVIEW IPC2322EBR5-DPZ28-C (192.168.2.12) - Camara

The option to set off alarms will be checked by default so that the alarms linked with all

zones will reach XProtect.

By checking the link camera option, you
zone alarm.

can specify which cameras will be linked to the

16
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Outputs

[v] Disparar alarmas
[ Asociar camara

Grupos

E--ﬂ DESKTOP-FMGEDPS

125 Grupo de grupo de camaras 1

4 hikvision

B uniview
-5 UNIVIEW IPC2322EBRS-DPZ28-C (192.168.2,
-0 UNIVIEW IPC232485-DZK-0 (192.168.2.54) -

UNIVIEW IPC232455-DZKA0 (192.168.2 54} - Camara 1
UNIVIEW IPC2322EBR5-DPZ28C (192.168.2.12) - Camara 1

17

Seleccionado:

& UNIVIEW IPC2322EBR5-DPZ28-C (192.168.2.12) - Camara
=0 UNIVIEW IPC232455-DZK-I0 (192.168.2.54) - Cdmara 1




Paradox Monitor - Installation and User Manual

Soluciones Globales de Seguridad Electrénica

XProtect Smart Client
Panels and their devices can be added to the plans in XProtect Smart Client.

[ T——
Selector de elemento n
Introducir filtro [ =

E E Paradox Monitor

4 ‘ panell

® prea

® Area3

Fonel
Fone2

= PGM1

= PGM2

= PGM3

By right-clicking on each of the plan elements, commands can be sent to the panel.

Armar area
Desarmar drea

Inhibir area

Forzar armado

Armado instantdneo

Retrasar armado

Omitir zona

Restaurar zona

Activar PGM
Desactivar PGM
Probar PGM

18
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8. Troubleshooting

Licences
The message that pops up when | try to load my licence on to the system does not
contain the details of the licence | have purchased.

Check if the "Licence.lic" file is in the "C:\Program Files\SGSE\SGSE Panel Integration
Service" folder. If the file is in this folder, contact technical support.

Error when connecting to the panel management server

Ha ocumido un emor con la conexidn al servidor de gestion de paneles. Revise la configuracion del servicio de gestion de paneles.

o 8:52:20 Ha ocurrido un ermor con la conexidn al servidor de gestion de paneles. Revise la configuracion del servicio de gestién de paneles.

An error message appears when | try to connect to the panel management server.

Check the plugin configuration in Tools > Options > Panel Management Server in the
XProtect Management Client and ensure that the access credentials are the same as those in
the "appsettings.json" file.

Further information
For more information, please see the information available online or contact SGSE at
the following email address: info@sgse.eu.

19




